Search found 35 matches

by Snake____1
Sat Jan 06, 2018 11:45 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

Re: BMW E36 rusEFI PnP #35 [Update 15/5-17]

Sorry for the late reply! I'm kind of lazy :mrgreen: Are you planning to publish the source files? This case whoever wants can modify your design also. Are there any threads about this on bmw forums? Any more videos? I would love to use this to advertise rusEfi a bit Took the liberty to commit this ...
by Snake____1
Sat Jan 06, 2018 7:31 pm
Forum: Software
Topic: MAP not showing any value
Replies: 11
Views: 1287

Re: MAP not showing any value

Also note, the VE table almost looks inverted for some odd reason... Any Idea as to why?
by Snake____1
Sat Jan 06, 2018 3:31 am
Forum: Software
Topic: MAP not showing any value
Replies: 11
Views: 1287

Re: MAP not showing any value

250kpa is a lot of forced induction! Yeah, I know. Hehe... 300kpa = 2bars of boost. I have a 3bar MAP sensor. I might swap it out for a MPXH6400A "4bar" over time. Running 1.5bars of boost isn't to uncommon for a forged engine :roll: So I would like to try 2bars at another date :mrgreen: Maybe you ...
by Snake____1
Sat Jan 06, 2018 12:46 am
Forum: Software
Topic: MAP not showing any value
Replies: 11
Views: 1287

Re: MAP not showing any value

Ah, I see! But it's limited to 250kpa... What does this limitation correlate to? 2018-01-06 01_45: EngineState: confirmation_mapinfo:7 2018-01-06 01_45: EngineState: instant value=256.08kPa 2018-01-06 01_45: EngineState: map type=0/MT_CUSTOM MAP=0.00kPa mapMinBufferLength=1 2018-01-06 01_45: EngineS...
by Snake____1
Fri Jan 05, 2018 10:38 pm
Forum: Software
Topic: MAP not showing any value
Replies: 11
Views: 1287

MAP not showing any value

Hi there,

Any suggestions on why the MAP value isn't showing up?

I have tried both PA0 and PA7 for comparison. @2.63v the MAP value is reading 0. On floating in a noisy 50hz enviroment MAP value bounces around 56kpa.

Just downloaded the new firmware 20180104_1855 and still no value.
by Snake____1
Mon May 15, 2017 5:35 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

Re: BMW E36 rusEFI PnP #35

Will this also be a direct drop-in for the E46 models? 1995-2001 323i E46 with the M52TUB25? (http://mywikimotors.com/m52b25/) If so...I wouldn't mind alpha/beta testing!!! ;) ;) No, this is for the Siemens MS41.0, MS41.1 and MS41.2 DME's. Came in E36, E39 and E38. But I am considering doing a MS42...
by Snake____1
Mon May 15, 2017 5:18 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

Re: BMW E36 rusEFI PnP #35

kb1gtt wrote:What KICAD version are you running? I'm on 4.0.5.
I'm on version 4.0.4.

Only Issue with the LT1129IST is the pin #4 missing, so this is a modified schematic component. :roll:
by Snake____1
Mon May 15, 2017 4:44 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

Re: BMW E36 rusEFI PnP #35

New update!

Project is ported to KiCAD and is following more of the rusEFI hardware guidelines! :)

Still only a 2-Layer board, 118x145mm. And remember, still only a prototype! :roll:

Managed to keep almost all components on the top side for ease of assembly :mrgreen:
M52top.jpg
Top render
M52top.jpg (177.7 KiB) Viewed 2965 times
M52bot.jpg
Bottom render
M52bot.jpg (110.56 KiB) Viewed 2965 times
by Snake____1
Sun Apr 23, 2017 2:48 pm
Forum: Hardware
Topic: stm32 LQFP48
Replies: 21
Views: 7327

Re: stm32 LQFP48

@russian
So does this mean rusEFI can run off the STM32F103C8 MCU? :D
or
Is this "just" a CAN converter "port expander"? :roll:
by Snake____1
Sun Apr 23, 2017 9:19 am
Forum: Software
Topic: ISO 9141-2 Diagnostics
Replies: 18
Views: 2629

ISO 9141-2 Diagnostics

Hi,

Is there a possibility to implement ISO 9141-2 Diagnostics to the code? Probably a shot in the dark, but I'm optimistic :)
by Snake____1
Tue Apr 18, 2017 7:05 pm
Forum: Hardware
Topic: BMW M52Bxx engine PnP board, first startup...
Replies: 22
Views: 2823

Re: BMW M52Bxx engine PnP board, first startup...

Learned something new today - usually it's the other way around. As did I, flashed the newest firmware and guess what? No trigger errors... No issues at all :D Time to get the car bench tested this weekend! :roll: I must say, WOW! Keep up the good work on the firmware! I see alot of new features. 8...
by Snake____1
Mon Apr 17, 2017 7:57 pm
Forum: Hardware
Topic: BMW M52Bxx engine PnP board, first startup...
Replies: 22
Views: 2823

Re: BMW M52Bxx engine PnP board, first startup...

@Dron_Gus, I'm currently at Crank sensor only. And this is a Hall sensor, Cam is going to be VR. Why should i pull C8 to BIAS1? I'm using hall, so VR- needs to be floating at 2.5v. @russian, I'll try to get some good captures up. I have both logic analyser and a cheap DSO. @kb1gtt, using seperate GN...
by Snake____1
Mon Apr 17, 2017 3:16 pm
Forum: Hardware
Topic: BMW M52Bxx engine PnP board, first startup...
Replies: 22
Views: 2823

Re: BMW M52Bxx engine PnP board, first startup...

Extremely limited telepathic abilities :( Please post a log file. Haha! So true, sorry for that! :mrgreen: I started a new log, and added current tune. :D At startup engine Idle position is ~53%, then slowly corrects itself. Also revving past 3350rpm gives trigger error, it does so if I select risi...
by Snake____1
Mon Apr 17, 2017 2:28 pm
Forum: Hardware
Topic: BMW M52Bxx engine PnP board, first startup...
Replies: 22
Views: 2823

Re: BMW M52Bxx engine PnP board, first startup...

I went over to the preveously planned MAX9926, but I'm having sync errors at 3.500rpm+ is it the layout maybe? I'll upload the schematics in a bit... Short video of error symptoms. Also, is there a way of telling the rusEFI to start at 38% idle after tps event or recovery? At the end of the video yo...
by Snake____1
Sun Apr 16, 2017 1:33 pm
Forum: Hardware
Topic: BMW M52Bxx engine PnP board, first startup...
Replies: 22
Views: 2823

Re: BMW M52Bxx engine PnP board, having startup issues...

@kb1gtt, D1 is used both as a protection and as an additional 0.7v voltage drop. As the Hall sensor of the M52 works at +12v :) @russian, indeed it is. Finally have some time at hand to continue the project! :geek: Also had some time to implement KiCad to my designs, so once I'm finished and have a ...
by Snake____1
Fri Apr 14, 2017 7:33 pm
Forum: Hardware
Topic: BMW M52Bxx engine PnP board, first startup...
Replies: 22
Views: 2823

BMW M52Bxx engine PnP board, first startup...

Hello, I'm trying to get my first startup with the M52Bxx board I made earlier. Attached are the .MSQ and a log of me trying to start the engine. It almost fires, but then trembles and fails. I've currently wired each injector and ignition coil: Cyl1 -> IGN1\INJ1 Cyl2 -> IGN2\INJ2 Cyl3 -> IGN3\INJ3 ...
by Snake____1
Sat Nov 05, 2016 2:06 pm
Forum: Hardware
Topic: HC-05 blue tooth
Replies: 12
Views: 1931

Re: HC-05 blue tooth

Sweet, and good job. Did you get the on working on the Frankenso board, or was it on it's own? If it was the frankenso, I believe you are the first to make that go. We have been using the FTDI chip. Once we had communications, @russian focused his energy and resources on other features. No, I used ...
by Snake____1
Sat Nov 05, 2016 1:58 pm
Forum: Hardware
Topic: rusEfi own wide band controller board add-on using CJ125
Replies: 301
Views: 24022

Re: CJ125 board

How do you actually control the heating element of the lambda probe? Do you have a temperature reference? I know you can use the Ur output for temperature monitor, and the Ua for lambda signal?
by Snake____1
Sat Nov 05, 2016 12:46 pm
Forum: Hardware
Topic: Automatic manual transmission
Replies: 9
Views: 1800

Re: Automatic manual transmission

Look into the BMW SMG gearboxes, they are fully self-contained units...

I'm currently working on an E46 5-speed SMG like the one pictured, when going from 5th to Reverse "going through every gear" it only takes 420ms!

Image
by Snake____1
Sun Oct 09, 2016 12:09 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

Re: BMW E36 rusEFI PnP

And here is the files I've put together this far. Sorry I saw your design rules after I made this. " 1206 is easier to solder tho' :mrgreen: " This works for all BMW's that use the M52B20, M52B25 and M52B28 engine. This came in 3-series E36, 5-series E39 and 7-series E38. "Some E39 and E38's communi...
by Snake____1
Sat Oct 08, 2016 11:27 pm
Forum: Software
Topic: Firmware issues?
Replies: 18
Views: 2082

Re: Firmware issues?

I am currently feeding a 60/2 signal directly via an Arduino, with built in cam generator. This runs at a steady 1000rpm. Signal on the Crank input: IMG_000.BMP Signal on the CAM input: IMG_001.BMP TS 4-Stroke with CAM "correct way" Still feeding crank Secondary, and cam primary signals: 4wc.png wc....
by Snake____1
Sat Oct 08, 2016 9:18 pm
Forum: Software
Topic: Firmware issues?
Replies: 18
Views: 2082

Re: Firmware issues?

So... I'm having a new issue. Just benchtesting now before trying it in my car I noticed it shows double the actual rpm's. Settings are 4stroke with cam, 60/2. Primary PA5, crank - 60/2 Secondary PC6, cam - single pulse. Thing is, when i choose 4stroke without cam, it shows actual rpm. If i switch o...
by Snake____1
Sat Oct 08, 2016 1:52 pm
Forum: Hardware
Topic: HC-05 blue tooth
Replies: 12
Views: 1931

Re: HC-05 Bluetooth module with rusEFI

For future reference...

For HC-05 use command; AT+UART=38400,0,0

Got it working! :mrgreen:
by Snake____1
Sat Oct 08, 2016 1:35 pm
Forum: Hardware
Topic: HC-05 blue tooth
Replies: 12
Views: 1931

HC-05 Bluetooth module with rusEFI

Hi there, using the HC-05 bluetooth ttl module. Just trying to configure the bluetooth module but I can't seem to get any connection... Tried using bluetooth direct in TS, and RS232 mode... I've configured it to 38400 baud, stop 1bit, pairity 2bit using command; AT+UART=38400,1,2 Any useful tips I c...
by Snake____1
Thu Oct 06, 2016 6:29 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

Re: BMW E36 rusEFI PnP

What is this created with - is it KiCad? Are you planning to publish the board files? No, I'm just using a "hobbyist" program called CopperConnection. If this works out and i fix any upcoming "flaws" I can upload the gerbers, so others can have fun with their BMW's too :D A little hard to get start...
by Snake____1
Thu Oct 06, 2016 4:26 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

Re: BMW E36 rusEFI PnP

@stefanst Thankyou. Everything "almost" is connected up to different pins, like ACrequest, EWS "immobilizer", tacho, CANbus and so on. So yes, I think I have everything covered so far. And yet spare pins :) @russian No this ECU uses the 88-pin. Maybe its the same as: http://www.te.com/catalog/pn/en/...
by Snake____1
Thu Oct 06, 2016 3:35 pm
Forum: Your car & your engine
Topic: BMW E36 rusEFI PnP #35 [Update 6/1-18]
Replies: 22
Views: 3784

BMW E36 rusEFI PnP #35 [Update 6/1-18]

Just testing things on my daily "smummer" driver. I've designed a PnP board that goes inside the orginal ECM box and fits the original connector. Going to implement bluetooth connection for tablet tuning. Engine model is a M52B28 :) UPDATE: 6/1-2018 So a summer later... Sorry for the wait. I have fi...
by Snake____1
Mon Oct 03, 2016 2:32 pm
Forum: Software
Topic: Firmware issues?
Replies: 18
Views: 2082

Re: Firmware issues?

Heh, sorry you had to see that. That was my fault not reading the datasheet of the nuf2101mt1g before placing it, I placed it 180 degrees wrong and sadly the magic smoke escaped! So i budged the D-&D+ without ESD protection, it's fine on the bench but I'm getting a new filter before I put the board ...
by Snake____1
Sun Oct 02, 2016 5:38 pm
Forum: Software
Topic: Firmware issues?
Replies: 18
Views: 2082

Re: Firmware issues?

OSH park had an issue with my boards, so instead of them replacing them i just "repaired" the ones i got. There was no connection to GND at C1.
by Snake____1
Sun Oct 02, 2016 4:54 pm
Forum: Software
Topic: Firmware issues?
Replies: 18
Views: 2082

Re: Firmware issues?

OK, long story short. Tacho output set to PD11 gives the FATAL error led...

Somehow I can't replicate the dead comm's fault at the moment. But I will keep trying :D