Troubleshoot J32A3 Rough Running

Tuning, troubleshooting and the nitty gritty of using rusEFI to make your engine run nicely!
Post Reply
flexus
Posts: 3
Joined: Wed Sep 09, 2020 4:25 am

Troubleshoot J32A3 Rough Running

Post by flexus »

Hello, so have a J32A3 sitting in the back of an '01 Chevy S10 Xtreme running Proteus 0.4. Using the stock Honda crank sensor with a custom 24-1 trigger wheel. Car starts fine but idle is horribly choppy and experiencing a steady increase in trigger errors. Throttle causes car to die. Setting timing to -40 deg sorta smoothens idle but still not happy. Despite this, timing offset was checked and rechecked and verified okay.

Video of car running here:



Video of the car running with -40deg timing:


Things checked:
- Injector spray pattern
- Fuel pressure
- Spark
- Firing Order
- Timing/ignition offset
- Timing belt has not jumped
- Went through relevant menus/settings and nothing is jumping out

We had a brief moment of enlightenment when we discovered the crank trigger was not grounded at the ECU, and that led us to discovering some poor soldering on the ECU connector pins. However, rectifying those issues did not change anything.

Logs tunes/here: https://drive.google.com/drive/folders/1eGHf1ggjnHILfxwtwnB3CU_PqDV8QT6Z?usp=sharing

Would love any help or pointers in the right direction. Thanks y'all
Attachments
types10_trigger_timing_Sweep2021-10-18_00.00.47.csv
(1.18 MiB) Downloaded 29 times
types10_trigger_log2021-10-17_23.58.26.csv
(565.63 KiB) Downloaded 29 times
Last edited by flexus on Mon Oct 18, 2021 6:04 am, edited 1 time in total.
User avatar
AndreyB
Site Admin
Posts: 12215
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Troubleshoot J32A3 Rough Running

Post by AndreyB »

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239
User avatar
AndreyB
Site Admin
Posts: 12215
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Troubleshoot J32A3 Rough Running

Post by AndreyB »

OMG that's the worst RPM log I've ever seen

Something is very very broken here. Custom trigger wheel is the largest red flag so far. Why do we have a custom trigger wheel again?
image.png
image.png (109.67 KiB) Viewed 700 times
Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239
mck1117
running engine in first post
running engine in first post
Posts: 1126
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: Troubleshoot J32A3 Rough Running

Post by mck1117 »

It's getting a trigger error every other cycle.

Inverted trigger fixed it :)

User avatar
AndreyB
Site Admin
Posts: 12215
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Troubleshoot J32A3 Rough Running

Post by AndreyB »

Is this default data rate? Please change to "Max data rate"

Is this AFR another red flag? Is this engine asking for more fuel?
image.png
image.png (134.32 KiB) Viewed 700 times
Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239
User avatar
AndreyB
Site Admin
Posts: 12215
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Troubleshoot J32A3 Rough Running

Post by AndreyB »

Next step: need your shipping address to provide you with rusEFI stickers.
Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239
mck1117
running engine in first post
running engine in first post
Posts: 1126
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: Troubleshoot J32A3 Rough Running

Post by mck1117 »

AndreyB wrote:
Mon Oct 18, 2021 4:35 am
Is this AFR another red flag? Is this engine asking for more fuel?
Sensor not connected and/or huge misfire (solved by invert :) )
flexus
Posts: 3
Joined: Wed Sep 09, 2020 4:25 am

Re: Troubleshoot J32A3 Rough Running

Post by flexus »

Obligatory first drive video:

User avatar
AndreyB
Site Admin
Posts: 12215
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Troubleshoot J32A3 Rough Running

Post by AndreyB »

Any chance to mention "#rusEFI" in video title? :)
Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239
Post Reply