Problem accessing SD card. Help!!

Post Reply
mx5newbie
Posts: 22
Joined: Sun Mar 20, 2022 4:14 am

Problem accessing SD card. Help!!

Post by mx5newbie »

I’m running the Hellen64 on my 1990 Miata. Trying to access the SD logs using my laptop. When I plug-in the USB to my laptop the drive does not come up. What am I missing, and Yes a SD card is installed.
Attachments
7C1FF7E8-B2A2-4725-BA29-91D0B0CF0409.jpeg
7C1FF7E8-B2A2-4725-BA29-91D0B0CF0409.jpeg (4.48 MiB) Viewed 14056 times
1990 Miata w/Mamba Td04-13T turbo, FIC 775cc injectors
User avatar
AndreyB
Site Admin
Posts: 14381
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Problem accessing SD card. Help!!

Post by AndreyB »

I might have seen this issue https://github.com/rusefi/rusefi/issues/5136

No idea what is causing it :(
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
mck1117
running engine in first post
running engine in first post
Posts: 1495
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: Problem accessing SD card. Help!!

Post by mck1117 »

what do the indicators at the bottom of TunerStudio show?
mx5newbie
Posts: 22
Joined: Sun Mar 20, 2022 4:14 am

Re: Problem accessing SD card. Help!!

Post by mx5newbie »

mck1117 wrote:
Thu Mar 23, 2023 1:31 am
what do the indicators at the bottom of TunerStudio show?
Neither indicator was lit.
1990 Miata w/Mamba Td04-13T turbo, FIC 775cc injectors
mx5newbie
Posts: 22
Joined: Sun Mar 20, 2022 4:14 am

Re: Problem accessing SD card. Help!!

Post by mx5newbie »

mck1117 wrote:
Thu Mar 23, 2023 1:31 am
what do the indicators at the bottom of TunerStudio show?
Ahh, thanks for sharing.
1990 Miata w/Mamba Td04-13T turbo, FIC 775cc injectors
i_s_64
Posts: 15
Joined: Tue Mar 14, 2023 1:15 am

Re: Problem accessing SD card. Help!!

Post by i_s_64 »

I have a similar issue on my RusEFI now. It was working great on my last laptop. It would pop up the RusEFI drive, as well as the SD Card as a separate drive whenever I plugged in my laptop. I could download the logs, delete them, do anything.

I stupidly dropped my laptop earlier this week and it refuses to turn on. The hard disk just clicks and spins. I ended up getting another laptop and installed Windows 10 and I'm able to change the tune on my Proteus and connected via COM Port on the Console as well, but it refuses to load any drive for the RusEFI anymore

I ended up taking the ECU to my desktop and plugging it in there and it's the exact same issue on my Windows 10 desktop. it will not load the drives there as well. The desktop can connect with TunerStudio and the Console app just fine, but I can't see the SD card on there.

The only way to get stored logs now (without driving around with my laptop) is to actually take out the SD Card out of the ECU case whenever I want to see the logs.

It has to be a driver issue, I just have no idea which one it would be. Anyone have an idea of what I can try? Indicators in TunerStudio are saying SD USB in Green and SD card OK in green
User avatar
Dron_Gus
contributor
contributor
Posts: 460
Joined: Wed Nov 13, 2013 1:11 pm
Location: S-Pb
Github Username: dron0gus

Re: Problem accessing SD card. Help!!

Post by Dron_Gus »

User avatar
AndreyB
Site Admin
Posts: 14381
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Problem accessing SD card. Help!!

Post by AndreyB »

Weird I am unable to reproduce on the laptop which was previously giving me issues. Could this whole thing be some power consumption magic or else? :(
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Dron_Gus
contributor
contributor
Posts: 460
Joined: Wed Nov 13, 2013 1:11 pm
Location: S-Pb
Github Username: dron0gus

Re: Problem accessing SD card. Help!!

Post by Dron_Gus »

AndreyB wrote:
Sun May 07, 2023 4:00 pm
Weird I am unable to reproduce on the laptop which was previously giving me issues. Could this whole thing be some power consumption magic or else? :(
My EG33 board with F7 that can be powered from external +12V source only shows same behavior.
i_s_64
Posts: 15
Joined: Tue Mar 14, 2023 1:15 am

Re: Problem accessing SD card. Help!!

Post by i_s_64 »

Dron_Gus wrote:
Sun May 07, 2023 11:58 am
Can someone with this issue try https://www.thesycon.de/eng/usb_descriptordumper.shtml ?
Information for device rusEFI Engine Management ECU (VID=0x0483 PID=0x5740):

------------------------------
Connection Information:
------------------------------
Device current bus speed: FullSpeed
Device supports USB 1.1 specification
Device supports USB 2.0 specification
Device address: 0x0004
Current configuration value: 0x00
Number of open pipes: 0


------------------------------
Device Descriptor:
------------------------------
0x12 bLength
0x01 bDescriptorType
0x0110 bcdUSB
0xEF bDeviceClass (Miscellaneous device)
0x02 bDeviceSubClass
0x01 bDeviceProtocol
0x40 bMaxPacketSize0 (64 bytes)
0x0483 idVendor
0x5740 idProduct
0x0200 bcdDevice
0x01 iManufacturer "rusEFI LLC"
0x02 iProduct "rusEFI Engine Management ECU"
0x03 iSerialNumber "29004C000951313135363634"
0x01 bNumConfigurations


-------------------------
Configuration Descriptor:
-------------------------
0x09 bLength
0x02 bDescriptorType
0x0062 wTotalLength (98 bytes)
0x03 bNumInterfaces
0x01 bConfigurationValue
0x00 iConfiguration
0x80 bmAttributes (Bus-powered Device)
0xC8 bMaxPower (400 mA)

Interface Descriptor:
------------------------------
0x09 bLength
0x04 bDescriptorType
0x00 bInterfaceNumber
0x00 bAlternateSetting
0x02 bNumEndPoints
0x08 bInterfaceClass (Mass Storage Device Class)
0x06 bInterfaceSubClass (Transparent SCSI subclass)
0x50 bInterfaceProtocol (Bulk only transport)
0x00 iInterface

Endpoint Descriptor:
------------------------------
0x07 bLength
0x05 bDescriptorType
0x81 bEndpointAddress (IN endpoint 1)
0x02 bmAttributes (Transfer: Bulk / Synch: None / Usage: Data)
0x0040 wMaxPacketSize (64 bytes)
0x00 bInterval

Endpoint Descriptor:
------------------------------
0x07 bLength
0x05 bDescriptorType
0x01 bEndpointAddress (OUT endpoint 1)
0x02 bmAttributes (Transfer: Bulk / Synch: None / Usage: Data)
0x0040 wMaxPacketSize (64 bytes)
0x00 bInterval

Interface Association Descriptor:
------------------------------
0x08 bLength
0x0B bDescriptorType
0x01 bFirstInterface
0x02 bInterfaceCount
0x02 bFunctionClass (Communication Device Class)
0x02 bFunctionSubClass (Abstract Control Model - ACM)
0x01 bFunctionProtocol (ITU-T V.250)
0x02 iFunction "rusEFI Engine Management ECU"

Interface Descriptor:
------------------------------
0x09 bLength
0x04 bDescriptorType
0x01 bInterfaceNumber
0x00 bAlternateSetting
0x01 bNumEndPoints
0x02 bInterfaceClass (Communication Device Class)
0x02 bInterfaceSubClass (Abstract Control Model - ACM)
0x01 bInterfaceProtocol (ITU-T V.250)
0x00 iInterface

CDC Header Functional Descriptor:
------------------------------
0x05 bFunctionalLength
0x24 bDescriptorType
0x00 bDescriptorSubtype
0x0110 bcdCDC

CDC Call Management Functional Descriptor:
------------------------------
0x05 bFunctionalLength
0x24 bDescriptorType
0x01 bDescriptorSubtype
0x00 bmCapabilities
0x02 bDataInterface

CDC Abstract Control Management Functional Descriptor:
------------------------------
0x04 bFunctionalLength
0x24 bDescriptorType
0x02 bDescriptorSubtype
0x02 bmCapabilities

CDC Union Functional Descriptor:
------------------------------
0x05 bFunctionalLength
0x24 bDescriptorType
0x06 bDescriptorSubtype
0x01 bControlInterface
0x02 bSubordinateInterface(0)

Endpoint Descriptor:
------------------------------
0x07 bLength
0x05 bDescriptorType
0x83 bEndpointAddress (IN endpoint 3)
0x03 bmAttributes (Transfer: Interrupt / Synch: None / Usage: Data)
0x0008 wMaxPacketSize (1 x 8 bytes)
0xFF bInterval (255 frames)

Interface Descriptor:
------------------------------
0x09 bLength
0x04 bDescriptorType
0x02 bInterfaceNumber
0x00 bAlternateSetting
0x02 bNumEndPoints
0x0A bInterfaceClass (CDC Data)
0x00 bInterfaceSubClass
0x00 bInterfaceProtocol
0x00 iInterface

Endpoint Descriptor:
------------------------------
0x07 bLength
0x05 bDescriptorType
0x02 bEndpointAddress (OUT endpoint 2)
0x02 bmAttributes (Transfer: Bulk / Synch: None / Usage: Data)
0x0040 wMaxPacketSize (64 bytes)
0x00 bInterval

Endpoint Descriptor:
------------------------------
0x07 bLength
0x05 bDescriptorType
0x82 bEndpointAddress (IN endpoint 2)
0x02 bmAttributes (Transfer: Bulk / Synch: None / Usage: Data)
0x0040 wMaxPacketSize (64 bytes)
0x00 bInterval

Microsoft OS Descriptor is not available. Error code: 0x0000001F


--------------------------------
String Descriptor Table
--------------------------------
Index LANGID String
0x00 0x0000 0x0409
0x01 0x0409 "rusEFI LLC"
0x02 0x0409 "rusEFI Engine Management ECU"
0x03 0x0409 "29004C000951313135363634"

------------------------------

Connection path for device:
USB xHCI Compliant Host Controller
Root Hub
rusEFI Engine Management ECU (VID=0x0483 PID=0x5740) Port: 1

Running on: Windows 10 or greater (Build Version 17134)

Brought to you by TDD v2.17.0, Feb 23 2021, 14:04:02
User avatar
Dron_Gus
contributor
contributor
Posts: 460
Joined: Wed Nov 13, 2013 1:11 pm
Location: S-Pb
Github Username: dron0gus

Re: Problem accessing SD card. Help!!

Post by Dron_Gus »

i_s_64 wrote:
Wed Aug 23, 2023 11:54 am
Dron_Gus wrote:
Sun May 07, 2023 11:58 am
Can someone with this issue try https://www.thesycon.de/eng/usb_descriptordumper.shtml ?
Information for device rusEFI Engine Management ECU (VID=0x0483 PID=0x5740):
Thanks. Looks like there is no issue with descriptors on Windows. Hope the problem is gone after increasing enumeration timeout.
Post Reply