Hellen128 / Burned Ignition driver mosfet

This means Hellen
Post Reply
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

Short story: programmed it to work with TB, Pedal, and enabled starter via firmware update and soldered P5 to P35 and P31, starter working correctly without failure.

Benched spark and both work, but I thought the spark order felt incorrect. Accidentally set ignition setting on spark to inverted default.

Burned the number "4" ignition driver.

It also wont recognize the ecu as it should on a second computer I have. And only as "unknown USB device" after a few seconds.

Ecu done for?

A few pictures.


Also number one of the drivers have lifted legs, one look like it has solder on it but not the other.


Edit: can confirm car runs good on stock ecu. Not a burned coilpack.

Short video on current lights flashing:
Last edited by FineWhine on Sat Oct 23, 2021 4:47 pm, edited 1 time in total.
User avatar
AndreyB
Site Admin
Posts: 14365
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Hellen128 / Burned Ignition driver mosfet

Post by AndreyB »

We have scary PCB discoloration

We have lifted IGBT lead.

And worst you say this does not connect to PC? That's the worst part. I would focus on this. Unless you have USB communication you have a paperweight. Please post pictures of the MCU area.

I have one board in stock I can sell discounted without case.

The lesson for us would be https://github.com/rusefi/rusefi/issues/3397
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Re: Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

AndreyB wrote:
Sat Oct 23, 2021 4:45 pm
We have scary PCB discoloration

We have lifted IGBT lead.

And worst you say this does not connect to PC? That's the worst part. I would focus on this. Unless you have USB communication you have a paperweight. Please post pictures of the MCU area.

I have one board in stock I can sell discounted without case.

The lesson for us would be https://github.com/rusefi/rusefi/issues/3397
MCU area looks fine, lifted IGBT leads might be badly soldered just
The discoloration I am not sure its gonna be an issue or that it caused any major damage.



I will try connecting to the laptop I do most stuff from.

EDIT: It connects and works on the laptop, but not my stationary desktop. Wierd.
Simon@FutureProof
contributor
contributor
Posts: 413
Joined: Tue Jul 24, 2018 8:55 pm
Github Username: Orchardperformance
Slack: Orchardperformance

Re: Hellen128 / Burned Ignition driver mosfet

Post by Simon@FutureProof »

So this seems to be an issue of the IGBT drivers being on 100% due to the inverted setting. This will have surely cooked them and probably hot enough to melt that solder joint.

It's possible they are now shorted to ground and causing issue elsewhere.

First step is going to be removing those IGBTs and checking if there is a short from anywhere to ground.

This might be salvageable, where in the world are you based?
Now keeping MRE in stock in the UK - https://www.FutureProofPerformance.com
User avatar
AndreyB
Site Admin
Posts: 14365
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Hellen128 / Burned Ignition driver mosfet

Post by AndreyB »

OrchardPerformance wrote:
Sat Oct 23, 2021 7:52 pm
where in the world are you based?
Safe to assume Sweden.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Re: Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

OrchardPerformance wrote:
Sat Oct 23, 2021 7:52 pm
So this seems to be an issue of the IGBT drivers being on 100% due to the inverted setting. This will have surely cooked them and probably hot enough to melt that solder joint.

It's possible they are now shorted to ground and causing issue elsewhere.

First step is going to be removing those IGBTs and checking if there is a short from anywhere to ground.

This might be salvageable, where in the world are you based?
Well, just my dumb luck finding shit like this I suppose. IGBT number one on board I can just solder back on, the heat from the burned IGBT shouldnt have unsoldered both legs if this was the case and bigger area would be affected if it did.

The other burned one probably just caused very localized damage, will have to desolder it and take a look.

But yeah, I live in sweden.

Lets remove the inverted setting on the next firmware update so it cannot mess anyone elses ECU.

I tried the other Wasted spark Ignition bank and it fires, just the IGN1 in ignition settings are burned. Starter and fuel pump priming aswell as throttle still works.
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Re: Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

BTW what mosfet is the injector driver one? I dont think I got any of the injectors to fire even once even before the burned IGBT.

Is it the one with lifted leads?
User avatar
AndreyB
Site Admin
Posts: 14365
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Hellen128 / Burned Ignition driver mosfet

Post by AndreyB »

Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Re: Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

Well, I am not into board building at all, so my knowledge is limited. But I see that its full product number is ISL9V3040S3S.

And some digging I see that its just a ignition driver.

Edit: all the fuses are in shape, none has blown. All resistors going to the ignition are fine as well.

I think I got somewhat lucky on those parts. just need a new IGBT.

Best would be to get a set of them incase something ever happens again :roll:
User avatar
AndreyB
Site Admin
Posts: 14365
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Hellen128 / Burned Ignition driver mosfet

Post by AndreyB »

FineWhine wrote:
Sun Oct 24, 2021 2:07 pm
Well, I am not into board building at all, so my knowledge is limited.
Do I read "Well, maybe I should _explicitly_ ask around for someone to solder those huge IGBT drivers(s) for me"?
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Re: Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

I am looking to order a few IGBTS.

https://www.mfgchips.se/products/AMI-Semiconductor-ON-Semiconductor/ISL9V3040S3S?fbclid=IwAR0sgdbUYbrBE1nY3ZpxI2k0Lr-w9yh8rNDcz4aii8Ets38qJDX2ReX8piU

These are the correct ones yes? I can consult a close radio shop to do the soldering in case I can't do it myself (most likely it will be not issue with a heat gun and a soldering iron).

Also, in case of I get a 6 cylinder M104 in the future, is soldering on IGBTS the only necessary thing to solder on some more of them?
User avatar
AndreyB
Site Admin
Posts: 14365
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Hellen128 / Burned Ignition driver mosfet

Post by AndreyB »

Yes https://octopart.com/search?q=ISL9V3040S3S is the correct chip - that's now documented on https://github.com/rusefi/rusefi/wiki/Hellen-128-Mercedes#spare-parts

Let's not discuss M104 on "Burned Ignition driver mosfet" thread. Maybe existing M104 thread would be a better place for M104 discussion.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Re: Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

AndreyB wrote:
Sun Oct 24, 2021 3:46 pm
Yes https://octopart.com/search?q=ISL9V3040S3S is the correct chip - that's now documented on https://github.com/rusefi/rusefi/wiki/Hellen-128-Mercedes#spare-parts

Let's not discuss M104 on "Burned Ignition driver mosfet" thread. Maybe existing M104 thread would be a better place for M104 discussion.
Can I substitute with the ISL9V3040S3ST model?
User avatar
AndreyB
Site Admin
Posts: 14365
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Hellen128 / Burned Ignition driver mosfet

Post by AndreyB »

Yes.

I believe that ISL9V3040S3ST is same ISL9V3040S3S just packaged in tape instead of tube or vice versa.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
FineWhine
Posts: 13
Joined: Thu Aug 26, 2021 6:07 pm
Location: Sweden

Re: Hellen128 / Burned Ignition driver mosfet

Post by FineWhine »

I tried the ECU today. And now both coils gives spark. I even got the car to run for a few seconds! Success in replacing the driver!
Post Reply