TS KIA TPS calibration

This means Hellen
Post Reply
User avatar
Kristian
Posts: 12
Joined: Sat Apr 09, 2022 10:34 pm
Location: New Xiland

TS KIA TPS calibration

Post by Kristian »

Hi, I'm having an issue with the TPS on a 91 Miata, I've recently purchased a 91 PNP hellen rev B unit. I have swapped out the TPS for a Kia unit,I have moved the pins around on the TPS connector and managed to calibrate the TPS thru TS tools. The values I get are ball park, foot off 260, foot on, 980. however on restart TS is coming up with an error, despite the TS throttle gauge showing 0-100% when I depress the throttle. Check configuration "Tps1Primary" problem :open 0.00/closed0.00 cal values are too close together. Check your calibration an wiring. What am I doing wrong?
1991 1.6 Mazda Eunos Roadster, 5sp, Normally Aspirated
User avatar
AndreyB
Site Admin
Posts: 14364
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: TS KIA TPS calibration

Post by AndreyB »

Sounds like calibration is not being saved.

Are you hitting 'burn'? Do you calibrate while engine is running? Do you see "unsaved changes" indicator in TS?

Try saving some other setting maybe vehicle name. Does that get saved?
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
BeerMoneyMotorsports
Posts: 151
Joined: Thu Jan 14, 2021 10:16 pm

Re: TS KIA TPS calibration

Post by BeerMoneyMotorsports »

Please attach screenshots and log link from reo. To note, you do not rewire for kia tps. It is pnp for us.
User avatar
Kristian
Posts: 12
Joined: Sat Apr 09, 2022 10:34 pm
Location: New Xiland

Re: TS KIA TPS calibration

Post by Kristian »

I'll repin back to original, I wasn't getting a reading before. will try starting again with fresh project. Thanks
1991 1.6 Mazda Eunos Roadster, 5sp, Normally Aspirated
User avatar
Kristian
Posts: 12
Joined: Sat Apr 09, 2022 10:34 pm
Location: New Xiland

Re: TS KIA TPS calibration

Post by Kristian »

re-pined to original, values are now backwards, but all errors are cleared. car starts, smell rich and rough, Hi idle (1400) and dies after a few seconds. So i guess I'm on the right track. thanks
1991 1.6 Mazda Eunos Roadster, 5sp, Normally Aspirated
Post Reply