1988 Mustang LX 5.0 ( Proteus Project )

Your chance to introduce yourself and your vehicle
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Hi All

I'm back for another round of RUSefi fun. This will be my third RUSefi project. Saw Andrey and Stephan at NJMP a few weeks back and now I'm building a Proteus for my 5.0.
This is my car.
6-11-22 R1 058.jpg
6-11-22 R1 058.jpg (3.71 MiB) Viewed 33953 times
This is the powerplant
IMG-1378.jpg
IMG-1378.jpg (3.47 MiB) Viewed 33953 times
NDLB5987.JPG
NDLB5987.JPG (4.35 MiB) Viewed 33953 times
With the Factory ECU it's best run was 11.083 @120.89mph all motor. First Objective is to get the Proteus running the car as well as it runs now. Then look at changing the car over from a distributor to distributor less ignition and see if improvements are to be had.

I have a Proteus and the ford 60 pin adapter board.
IMG_4164.JPG
IMG_4164.JPG (3.81 MiB) Viewed 33953 times
I've run into a number of issues so far. The largest is the pinouts explained for the 60 pin in other threads is not what I'm seeing on the board tracing leads. So I have the multimeter out tracing leads right now just to make sure all connections are there or where ever they are and getting them corrected.
stefanst
contributor
contributor
Posts: 703
Joined: Wed Feb 17, 2016 12:24 am
Location: USA 08530

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by stefanst »

Welcome back!
Can you please reference where you found the pinouts that don't agree with what you have, so we can verify?
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

It's about https://github.com/rusefi/proteus-mustang5.0-60-pin

Let's focus on having TPS working, that's kind of basic. Looks like we agree on GND pin vehicle46 and +5v pin vehicle26 and TPS signal on vehicle47 routed to Proteus AV#8 but sensor is not sensing.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

So after trying to run with the 60 pin board from the above pictures I ran into a couple issues.

1. The fuel pump ran constantly
2. The TPS would not read correctly at all.
3. ECT and ACT were not measuring correctly.

So my hope/expectation after deeper diagnosis is many of these issues were created by the adapter board I was using. Tomorrow I will hopefully have enough time to complete testing this configuration and if I'm right my only issues left will be to figure out what type of temp sensors I have so they will read correctly. I don't believe the default are working right.

More to come.
Attachments
IMG_4241.jpg
IMG_4241.jpg (2.37 MiB) Viewed 33726 times
IMG_4240.jpg
IMG_4240.jpg (2.14 MiB) Viewed 33726 times
nmstec
contributor
contributor
Posts: 124
Joined: Tue Oct 05, 2021 9:02 pm
Location: Vancouver

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by nmstec »

recommendation: use the old explorer cam sensor. Its direct replacement for the distributor https://www.therangerstation.com/tech_library/camshaft_position_sensor_cmp.shtml
"Dave B. 5:03 PM
Mark is an ass but by far the most potent combination of knowledgeable ass, smart ass, get it done ass and determined ass. and his ass consistently puts in time."

-Dave B, Hero, Tuner, and probably has a car.
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

When I get to that part I will take your advice and look into that.
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

So I got a chance to test my adapter cable and amazingly a lot fo things are working much better. There are apparently many issues to sort out with the adapter board.

1. TPS appears to work correctly now.
2. Fuel Pump appears to work correctly now.
3. Temp sensors and MAP sensor are not reading correctly. I have not gone through and tested all the different sensors with the new cable yet. That's the next move on this one.

So the adapter board is what created most of the nightmare so far. Any help on what sensors are similar to the factory mustang sensors for MAP, CLT and ACT. Should be able to have this running soon.
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

Wow

https://github.com/rusefi/proteus-mustang5.0-60-pin/issues/14 created sounds like we are ready for EE-capable people to evaluate at least the TPS and fuel pump part of the https://github.com/rusefi/proteus-mustang5.0-60-pin/ design
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Ok so today I found what I think is the ford sensor info for my car. The IAT and ECT seem to be reading correct. It was 70 degrees outside and the engine air and ECT were reading in the high 60's 67/69 degrees. So I think what I entered is reasonable close. was hoping someone on here could look at this and validate or tell me what I've got wrong. I think I'm very close to trying to fire the car.

My open issues list so far is.

- Bench Test is not working. Even though the fuel pump appears to prime and I can change the time settings and they seem to take. When I go into bench test and click fuel pump I get nothing. This also goes for the Injectors I hear nothing but suspect the ECU can see them and they are wired correctly. I think this is a bench test issue from within tuner studio. This is making me nervous about turning the start key.

- I also have a timing question. At the factory Ford sets the Distributor at 10 degrees. So if I tell tuner Studio 30 degrees of timing am I giving it a total of 40 is my thinking. Is this thinking correct?

Once I figure these out I think it might be ready to fire.
Attachments
Screenshot 2022-08-14 095720.jpg
Screenshot 2022-08-14 095720.jpg (281.54 KiB) Viewed 33564 times
Sensors Page 2.jpg
Sensors Page 2.jpg (156.56 KiB) Viewed 33564 times
Sensors Page 1.jpg
Sensors Page 1.jpg (211.97 KiB) Viewed 33564 times
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

Please try bench test from ruzEFI console. If that hrlps jpdate all software.

TS bench was broken, fixed maybe a mongh ago
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

AndreyB wrote:
Sun Aug 14, 2022 2:26 pm
Please try bench test from ruzEFI console. If that hrlps jpdate all software.

TS bench was broken, fixed maybe a mongh ago
The SW I have is 2 month old. After I posted that I went to look and see how far behind I was. So I'm in the process of updating all the SW now anyhow. so I'll try that and if that's still not working I'll go to the console. Thanks.
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

AndreyB wrote:
Sun Aug 14, 2022 2:26 pm
Please try bench test from ruzEFI console. If that hrlps jpdate all software.

TS bench was broken, fixed maybe a month ago
Ok so the Upgrade fixed the test bench in TS. I have injectors but I lost my IAT,CLT and other settings when I upgraded. If anyone can explain how to upgrade without loosing settings that would be helpful. I most likely didn't do something right.

I found the offset for the timing so I have that worked out. I think it might be ready to start.
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Well gave it a shot and it did not start. Appears to be a spark issue. Not quite sure where. Cylinders smell like gas so it's getting fuel and air. Everything else appears to be working.
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Ok Looking for some help verifying what I'm thinking is wrong with my Ignition setup.

Pin 4 on the ECU goes to the Coil and the Dist. but it's wired to Analog Inp 5 (This was taken from the original adapter board configration)

Pin 56 is the PIP and This is Wired to Digital Hall 1

Pin 16 id ground and goes to ground

Pin 36 goes to the Distributor Spout and is wired to Digital Hall 3.

My suspicion is Pin 4 needs to be moved to one of the IGN pins and set as the single coil. Everything else should be fine. Is this correct thinking?
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Latest news I have spark now. Running though checking timing and few other things and then we'll add Gas back and see if it runs.
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

Kyocmondeo wrote:
Sun Aug 21, 2022 3:21 pm
Latest news I have spark now.
Where was it hiding and how did you find it?

I was thinking about you and your spark while getting ready for bed yesterday :)
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

AndreyB wrote:
Sun Aug 21, 2022 3:30 pm
Kyocmondeo wrote:
Sun Aug 21, 2022 3:21 pm
Latest news I have spark now.
Where was it hiding and how did you find it?

I was thinking about you and your spark while getting ready for bed yesterday :)
Well I'm not sure it was hiding. but I'm not sure my spark is working right. When I test it, it does not appear to be adjusting. So I goin a set timing a not dynamic and set it to 0 degrees. When I crank the car the spark is at 14 degrees. Now this is technically correct because the distributor is installed at 14 degrees not 0. But if I change the spark setting from 0 to 20 degrees it does not move. it's still showing 14 degrees. So it does not appear proteus can see my distributor. I'm not sure at this point where to look.
Attachments
Ignition.jpg
Ignition.jpg (87.04 KiB) Viewed 33319 times
Trigger.jpg
Trigger.jpg (118.62 KiB) Viewed 33319 times
base.jpg
base.jpg (90.06 KiB) Viewed 33319 times
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Ok so we tried changing the Ignition signal from the IDM PIN4 on the ecu to the spout wire. Now I'm not sure what's up with the proteus board sending back for analysis. So don't try that.

I'm attaching the wiring diagram for the car. Stephan after you see this give me a call thanks.
Attachments
88-91_5.0_EEC_Wiring_Diagram.gif
88-91_5.0_EEC_Wiring_Diagram.gif (77 KiB) Viewed 32873 times
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Hey Stephan you were right about the spout controlling the timing



This video explain and shows how the signals work from the PIP and Spout. The IDM or Pin4 is the coil wire. It's the spout that controls ignition timing not sure how to interpret the signal discussion in the video here but I think it explains very well what's going on.

Pin56 - PIP is the base dist signal wire. Maybe this should be used like a crank sensor
Pin4 - IDM goes to the coil ground

Pin 36 - is the spout this is the wire that controls spark advance everything I see says it's a input wire.
stefanst
contributor
contributor
Posts: 703
Joined: Wed Feb 17, 2016 12:24 am
Location: USA 08530

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by stefanst »

Kyocmondeo wrote:
Mon Sep 12, 2022 5:06 pm
Hey Stephan you were right about the spout controlling the timing



This video explain and shows how the signals work from the PIP and Spout. The IDM or Pin4 is the coil wire. It's the spout that controls ignition timing not sure how to interpret the signal discussion in the video here but I think it explains very well what's going on.

Pin56 - PIP is the base dist signal wire. Maybe this should be used like a crank sensor
Pin4 - IDM goes to the coil ground

Pin 36 - is the spout this is the wire that controls spark advance everything I see says it's a input wire.
You are correct. The PIP is actually a CAM sensor, since it's driven by the camshaft, so only one rotation per full cycle. SPOUT is what we need to drive from the rusEFI board.
For initial testing, let's keep the SPOUT disconnected and just connect the PIP. crank the engine and take a log with the engine sniffer in the console. Then let's make sure that signal is interpreted correctly.
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

Test with no ECU attached PIP Signal test with volt meter.

KEY OFF
.17 voltage reading.

KEY OFF CRANKING
.00 Voltage reading

KEY ON
.05 Voltage Reading

KEY ON CRANKING
4.98 Peak Voltage reading (bounced around)
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

How is the fancy cable - can you now have laptop while cranking in the cabin?

Please provide exact URL of tune and log on rusEFI online

We have trigger->triggerVvtXXX counters to confirm life on the wire
image.png
image.png (54.82 KiB) Viewed 32559 times
also in console we have readPin command like

readPin PC6
readPin PE12

depend on what digital input you want to read directly see https://github.com/rusefi/rusefi/blob/master/firmware/config/boards/proteus/connectors/black23.yaml for all Pxyy values for digital
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

The Cable is very fancy and works very well thank you very much....

So let me see if I get you correctly. You want me to setup gages for....

triggerPrimaryFall and triggerPrimaryRise and that will read the trigger wire for any input.

You're not expecting me to use triggerVvtFall correct?
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

ok so I was able to run the trigger gage test. I added the gages in the pic. When I crank the car the 0.000 in the gage starts counting. The needles didn't seem to move at all. But if I'm understanding you correctly this is the signal we're seeing on the wire.

Now the million dollar question is why do I not get a RPM reading?????
Attachments
Screenshot 2022-09-29 153337.jpg
Screenshot 2022-09-29 153337.jpg (22.54 KiB) Viewed 32403 times
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

Please paste exact URL of your current tune and a log of cranking attempt at https://rusefi.com/online

All the answers are there, in the tune and in the logs :)

Events coming in is great news!!!
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Kyocmondeo
Posts: 56
Joined: Sun Feb 15, 2015 2:43 am

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by Kyocmondeo »

https://rusefi.com/online/view.php?msq=1243

Thats the Tune I tried uploading a log and it didn;t seem to like it. So I attached it here.
Attachments
re_220920_113837.zip
(310.34 KiB) Downloaded 348 times
stefanst
contributor
contributor
Posts: 703
Joined: Wed Feb 17, 2016 12:24 am
Location: USA 08530

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by stefanst »

The log doesn't tell me much. There are no fields that seem to contain pertinent data on the trigger. Could somebody with more knowledge please chime in and say which fields would be helpful if logged?

To summarize the problem: When cranking, the edge counters increase, but we don't see rpm. A test in the engine sniffer didn't show any trigger info.
User avatar
AndreyB
Site Admin
Posts: 14218
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 1988 Mustang LX 5.0 ( Proteus Project )

Post by AndreyB »

Please use TS logs not SD card logs :( Only the TS logs have all the sweet data at the moment :(

We log 600 data points via Tuner Studio "start log" button
At the moment SD card has only about 60 data points :(

https://github.com/rusefi/rusefi/issues/3985
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Post Reply