[rusEfi] Mitsubishi 4G63 and 4G92 (#6)

Your chance to introduce yourself and your vehicle
Post Reply
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Mitsubishi 4G63 and 4G92 (#6)

Post by Tambralinga »

Help me please
I connect analog tps clt Tunestudio unresponsive .
TPS = PA0
CLT = PA1
I'm not sure what to do.
I want pin out for Frankenstein and setting Tunestudio
Thank you
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Firmware developent status

Post by AndreyB »

set_engine_type 16

mitsubishi.cpp

Mitsu trigger
Image

http://www.msextra.com/forums/viewtopic.php?f=4&t=35289#p259279
http://www.msextra.com/doc/ms1extra/MS_Extra_Ignition_Hardware_Manual.htm#4g63

trigger sensor pics: http://rusefi.com/forum/viewtopic.php?f=3&t=622&start=30#p9966

4G93 '1994
Import form Japan like Asti 2 doors.

Engine 1800 CC,
Injection 275 CC

Status update: status unclear
[video][/video]
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Firmware developent status

Post by Tambralinga »

Skype Id : Shiva-p
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

You guys have made some great progress!
Image
Image
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

The commands which would help you with CLT and IAT are tempinfo and analoginfo (there is no analoginfo in simulator because there is no real analog in simulator, not sure why it is crashing in your case - I cannot reproduce this, it does not crash in my case)

What is your trigger wheel shape? Do you know your CLT and IAT sensors parameters? If you provide me with all the info I can create you an engine configuration file so that you have less to configure via Tuner Studio - it would be like dodge_neon.cpp or mazda_miata_nb.cpp
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

The new one images. kidding project.
:D :D :D
FK Board.
Image
Sim Board.
Image

Thanks,
Mr.X
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

I've just realized that you use http://rusefi.com/forum/viewtopic.php?f=4&t=381 - wow once again.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

So, to troubleshoot your Tuner Studio issue with real hardware

1) step 1: put a jumper between GND and pin PB1 - this would move TS from uart to USB pin. Does TS work this way?

2) step 2: remove the jumper, go back to FL232 usb<>UART mode. Connect with putty using proper speed - 38400 - and hit 't' in putty. Do you get a response?

3) how confident are you about your soldering? does windows recognice FL232 as COM port?
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

i can open TS by not need program simulator?
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

I do not understand :( ask it differently, with more details?
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »




In this test case we connect STM32 Discovery and ECU simulator (The voltage developed by the VR sensor) to Tuning Studio over serial port. First time success, The STM32 Discovery coding by to read the values form VR sensor and send the data to serial port and Tuning Studio to read these results and display in Gauge dashes. That working fine.


However after we turns off and then turn on the system all the TS dashes are not working when we moving some Gauge. I had make mistake?

I want to use TS without using the dev console and solfware simulator.
Sometimes the connection ้hardware simulator is ok.
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Let's check that I get it right:
1) you are using rusEfi with real stm32 hardware, not the windows simulator
2) you are connecting TunerStudio via FT232R serial/TTL chip
3) when you create a new project it works fine
4) if you restart something, things get broken.

Is it the situation?
When you say 'we turn off' - what exactly do you turn off? Do you restart Tuner Studio? Do you restart rusEfi with the black button? Do you turn power off?

Please try and check a couple of things
1) please be sure to use latest version of the firmware, please update if needed
2) please put a jumper or a jumper wire between GND and pin PB1. This would temporarily move TunerStudio to the stm32 USB port. Does it work in this configuration?
3) when Tuner Studio does not work, please connect to that port with putty and press 't' button. Does the port respond 'Alive' as it should respond?
4) In Tuner Studio, remove the log file and set 'Communication->Debug Log Comm' checkbox, and attach the full logs here I will see if I see any issues with the logs.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

micro usb on board stm32 can connect TS ok port respond 'Alive'

port TTL usb PC10,PC11 not ok have respond in picture(put jumper GND to pin PB1)

Image

port uart putty no response
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

russian wrote:please be sure to use latest version of the firmware, please update if needed
Looking at that screen shot I suspect that you are using an old version. Sometimes older versions have issues and these issues are resolved in newer versions.

Please update to the current version. I think that this issue has already been resolved in the current firmware version. Please take fresh binary & rusefi.ini from http://rusefi.com/build_server/
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

new firmware

port TTL usb PC10,PC11 Jump GND to PB1 putty display

Image

port TTL usb PC10,PC11 remove GND to PB1 putty display

Image

Why port TTL no respond 'Alive'?
no connect to Ts
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Tambralinga wrote:Why port TTL no respond 'Alive'?
no connect to Ts
Please set serial speed to 38400 in putty and TS.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

Thanks for the great answers. :D

Help on how to test the injectors to test it.
because Injectors not working
for 4 injectors( 12v. to injector+ ) (injector GND to INJ-12)
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Tambralinga wrote:Thanks for the great answers. :D
Did it help?
Tambralinga wrote: Help on how to test the injectors to test it.
because Injectors not working
for 4 injectors( 12v. to injector+ ) (injector GND to INJ-12)
Can you test it with an LED and a resistor? Does the LED blink at all?

To test the board and the chips you can use http://rusefi.com/wiki/index.php?title=Manual:Software:User/en#Board_Testing_mode

Do you see injectors active in the dev console, is the firmware even trying to fire the injectors?
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

I have problem to connect to the real Injector with stm32.
Just do it via dev console.
1) showconfig - does it show the right pin for the injector?
It is like this img....
Image

2) digiral sniffer - does it show injection pulses?
That is
Image

Thanks.
Mr.X
Skype : shiva-p
+66 8 5357 5159
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

Hi Andrey.
Regarding to latest version, I've test injector connect to LED it still lighting (Not blinking).
Then, I was test firmware in the older version like Rev.3349.
The injector still working good as clip video.

[video][/video]

And pulses like...

Image

What it happen ?
Thanks,
Mr.X
Skype : shiva-p
+66 8 5357 5159
User avatar
kb1gtt
contributor
contributor
Posts: 3732
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA

Re: Mitsubishi 4G63 and 4G92

Post by kb1gtt »

I see this as a 100mS pulse width with about 95% duty cycle. I would expect this to be hard to see with the LED and the eye. Perhaps you can get something closer to 50% duty cycle.

Also when the MOSFET is off, there will still be a leakage current through the MOSFET. I see the datasheet notes that Idss is around 30uA, which should not make the LED bright. When the injector is off, does the LED go dark? It's possible the LED is going bright with the leakage current through the MOSFET. It often doesn't take much to make an LED go bright.
Welcome to the friendlier side of internet crazy :)
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

I am looking into this, you have convinced me that the problem could be on my side :)
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Good job @! If was a good idea to try an older version.

The bug was introduced in version 3923 and I've just fixed it - please update to latest version from http://rusefi.com/build_server/
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

Hi, Man

I was test the firmware Rev.4048.
- It have no LED status.
Image

- The stm32 is lack when I burn some value in Tuning Studio.
Please see the video.
[video][/video]

Thanks.
Mr.X
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Tambralinga wrote:I was test the firmware Rev.4048.
- It have no LED status.
The blue LED has to blink. If it does not blink then something bad is going on - see http://rusefi.com/wiki/index.php?title=Manual:Software:User/en#LEDs

Let's figure this out. Can you please connect to dev console port with dev console? Does it show any errors in the 'Messages' area? If dev console does not connect, please connect to dev console port with putty. I suspect there will be an error message there.
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
Tambralinga
donator
donator
Posts: 174
Joined: Wed Jun 18, 2014 8:36 am
Location: Bangkok, Thailand

Re: Mitsubishi 4G63 and 4G92

Post by Tambralinga »

russian wrote:
Tambralinga wrote:I was test the firmware Rev.4048.
- It have no LED status.
The blue LED has to blink. If it does not blink then something bad is going on - see http://rusefi.com/wiki/index.php?title=Manual:Software:User/en#LEDs

Let's figure this out. Can you please connect to dev console port with dev console? Does it show any errors in the 'Messages' area? If dev console does not connect, please connect to dev console port with putty. I suspect there will be an error message there.

Code: Select all

line:194:time,877.413,rpm,1199,maf,0.98,MAP,168.01,map_r,167.59,baro,459.92,afr,10.97,vref,0.98,vbatt,2.62,TP,10.46,CLT,70.00,MAT,30.00,ckp_c,87587,fuel_base,17.01,fuel_lag,25.50,fuel,42.51,timing,87.34,
line:3921:wave_chart,c2!d!0_7!inj2!d!757!inj3!u!1501!c2!u!1551_8!spa1!u!1569!spa1!d!1973!c2!d!2485_9!inj1!d!3262!c1!u!3320_0!c2!u!4007_1!inj4!u!4027!spa1!u!4071!spa1!d!4474!c2!d!4967_2!inj3!d!5751!r!1199!5754!c2!u!6481_3!inj2!u!6509!spa1!u!6578!spa1!d!6980!c2!d!7439_4!inj4!d!8281!c1!d!8315_5!inj1!u!9011!c2!u!9059_6!spa1!u!9079!spa1!d!9467!c2!d!10005_7!inj2!d!10761!inj3!u!11510!c2!u!11548_8!spa1!u!11569!spa1!d!11973!c2!d!12489_9!inj1!d!13265!c1!u!13317_0!c2!u!14010_1!inj4!u!14022!spa1!u!14070!spa1!d!14474!c2!d!14963_2!r!1200!15750!inj3!d!15763!c2!u!16482_3!inj2!u!16508!spa1!u!16577!spa1!d!16979!c2!d!17436_4!inj4!d!18275!c1!d!18312_5!inj1!u!19005!c2!u!19055_6!spa1!u!19073!spa1!d!19461!c2!d!20002_7!inj2!d!20760!inj3!u!21503!c2!u!21551_8!spa1!u!21569!spa1!d!21973!c2!d!22485_9!inj1!d!23259!c1!u!23320_0!c2!u!24007_1!inj4!u!24024!spa1!u!24069!spa1!d!24472!c2!d!24967_2!r!1199!25752!inj3!d!25757!c2!u!26479_3!inj2!u!26504!spa1!u!26574!spa1!d!26976!c2!d!27439_4!inj4!d!28278!c1!d!28315_5!inj1!u!29009!c2!u!29059_6!spa1!u!29077!spa1!d!29465!c2!d!30005_7!inj2!d!30757!inj3!u!31508!c2!u!31548_8!spa1!u!31567!spa1!d!31971!c2!d!32489_9!inj1!d!33263!c1!u!33317_0!c2!u!34010_1!inj4!u!34020!spa1!u!34070!spa1!d!34474!c2!d!34963_2!r!1200!35751!inj3!d!35762!c2!u!36482_3!inj2!u!36508!spa1!u!36577!spa1!d!36979!c2!d!37436_4!inj4!d!38274!c1!d!38319_5!inj1!u!39011!c2!u!39055_6!spa1!u!39079!spa1!d!39461!c2!d!40002_7!inj2!d!40760!inj3!u!41503!c2!u!41551_8!spa1!u!41569!spa1!d!41973!c2!d!42485_9!inj1!d!43265!c1!u!43321_0!c2!u!44007_1!inj4!u!44025!spa1!u!44069!spa1!d!44472!c2!d!44967_2!r!1199!45752!inj3!d!45757!c2!u!46479_3!inj2!u!46504!spa1!u!46574!spa1!d!46976!c2!d!47439_4!inj4!d!48279!c1!d!48316_5!inj1!u!49009!c2!u!49059_6!spa1!u!49077!spa1!d!49465!c2!d!50005_7!inj2!d!50757!inj3!u!51508!c2!u!51547_8!spa1!u!51566!spa1!d!51970!c2!d!52489_9!inj1!d!53263!c1!u!53317_0!c2!u!54010_1!inj4!u!54020!spa1!u!54074!spa1!d!54474!c2!d!54963_2!r!1200!55750!inj3!d!55761!c2!u!56482_3!inj2!u!56508!spa1!u!56577!spa1!d!56979!c2!d!57436_4!inj4!d!58274!c1!d!58312_5!inj1!u!59005!c2!u!59055_6!spa1!u!59073!spa1!d!59461!c2!d!60002_7!inj2!d!60760!inj3!u!61503!c2!u!61551_8!spa1!u!61569!spa1!d!61973!c2!d!62485_9!inj1!d!63259!c1!u!63320_0!c2!u!64007_1!inj4!u!64025!spa1!u!64069!spa1!d!64472!c2!d!64967_2!r!1199!65752!inj3!d!65757!c2!u!66479_3!inj2!u!66505!spa1!u!66574!spa1!d!66976!c2!d!67439_4!inj4!d!68278!c1!d!68315_5!inj1!u!69009!c2!u!69059_6!spa1!u!69077!spa1!d!69466!c2!d!70005_7!inj2!d!70757!inj3!u!71508!c2!u!71547_8!spa1!u!71566!spa1!d!71970!c2!d!72489_9!inj1!d!73263!c1!u!73317_0!c2!u!74010_1!inj4!u!74020!spa1!u!74074!spa1!d!74474!c2!d!74963_2!r!1200!75750!inj3!d!75762!c2!u!76482_3!inj2!u!76508!spa1!u!76577!spa1!d!76979!c2!d!77436_4!inj4!d!78274!c1!d!78319_5!inj1!u!79012!c2!u!79055_6!spa1!u!79079!spa1!d!79461!c2!d!80002_7!inj2!d!80760!inj3!u!81503!c2!u!81551_8!spa1!u!81569!spa1!d!81973!c2!d!82485_9!inj1!d!83266!c1!u!83320_0!c2!u!84007_1!inj4!u!84025!spa1!u!84069!spa1!d!84471!c2!d!84967_2!r!1199!85752!inj3!d!85757!c2!u!86479_3!inj2!u!86504!spa1!u!86574!spa1!d!86976!c2!d!87439_4!inj4!d!88279!c1!d!88315_5!inj1!u!89009!c2!u!89059_6!spa1!u!89077!spa1!d!89465!c2!d!90005_7!inj2!d!90757!inj3!u!91508!c2!u!91547_8!spa1!u!91566!spa1!d!91970!c2!d!92489_9!inj1!d!93263!c1!u!93317_0!c2!u!94010_1!inj4!u!94020!spa1!u!94070!spa1!d!94474!c2!d!94963_2!r!1200!95751!inj3!d!95762!c2!u!96482_3!inj2!u!96508!spa1!u!96577!spa1!d!96979!c2!d!97435_4!inj4!d!98274!c1!d!98312_5!inj1!u!99005!c2!u!99055_6!spa1!u!99073!spa1!d!99461!c2!d!100002_7!inj2!d!100760!inj3!u!101503!c2!u!101551_8!spa1!u!101570!spa1!d!101974!c2!d!102485_9!inj1!d!103259!c1!u!103320_0!c2!u!104007_1!inj4!u!104025!spa1!u!104069!spa1!d!104471!c2!d!104967_2!input1 A8!d!105565!r!1199!105752!inj3!d!105757!input1 A8!u!105965!c2!u!106479_3!inj2!u!106505!spa1!u!106574!spa1!d!106977!c2!d!107439_4!inj4!d!108279!c1!d!108315_5!inj1!u!109009!c2!u!109059_6!spa1!u!109077!spa1!d!109466!c2!d!110005_7!,
line:194:time,877.971,rpm,1199,maf,0.99,MAP,167.97,map_r,168.54,baro,461.68,afr,10.98,vref,0.99,vbatt,2.64,TP,10.61,CLT,70.00,MAT,30.00,ckp_c,87643,fuel_base,17.01,fuel_lag,25.50,fuel,42.51,timing,87.34,
line:218:analog_chart,0.00000|0.00000|49.42996|2001.00000|118.45639|3002.00000|227.24404|2003.00000|296.32083|3004.00000|359.36901|1005.00000|412.85644|2006.00000|480.91885|3007.00000|591.88629|2008.00000|659.61059|3009.00000|,
line:194:time,878.205,rpm,1199,maf,0.99,MAP,167.95,map_r,168.48,baro,463.15,afr,10.98,vref,0.99,vbatt,2.64,TP,10.61,CLT,70.00,MAT,30.00,ckp_c,87667,fuel_base,17.01,fuel_lag,25.50,fuel,42.51,timing,87.34,
line:194:time,878.424,rpm,1199,maf,0.97,MAP,167.90,map_r,168.70,baro,462.85,afr,10.95,vref,0.97,vbatt,2.61,TP,10.30,CLT,70.00,MAT,30.00,ckp_c,87688,fuel_base,17.01,fuel_lag,25.50,fuel,42.51,timing,87.34,
line:194:time,878.640,rpm,1200,maf,0.98,MAP,167.94,map_r,168.26,baro,461.68,afr,10.97,vref,0.98,vbatt,2.63,TP,10.46,CLT,70.00,MAT,30.00,ckp_c,87710,fuel_base,17.01,fuel_lag,25.50,fuel,42.51,timing,87.34,
line:194:time,878.856,rpm,1200,maf,0.98,MAP,167.92,map_r,168.15,baro,461.39,afr,10.97,vref,0.98,vbatt,2.63,TP,10.46,CLT,70.00,MAT,30.00,ckp_c,87732,fuel_base,17.01,fuel_lag,25.50,fuel,42.51,timing,87.34,
Skype : shiva-p
+66 8 5357 5159
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Weird - that's the normal messages so looks like no errors, yet the blue is not blinking and it HAS to blink.

Can you please reset configuration as described at http://rusefi.com/wiki/index.php?title=Manual:Software:User/en#Configuration_reset
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
kb1gtt
contributor
contributor
Posts: 3732
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA

Re: Mitsubishi 4G63 and 4G92

Post by kb1gtt »

The LED's on the injectors may want an additional diode. I can not clearly see if there is already such a diode or not. The MOSFET driver(s) allow the injector voltage to jump up to 40V. Most LED's can not block this voltage, and after some time to fatigue, the LED's will fail. Often the solution is to put a schottky diode or similar diode in series with the LED. A schottky will typically have a suitable reverse voltage blocking / break down voltage. If such a diode is not already installed, I would like to recommend the use of something similar to this diode http://octopart.com/partsearch#!?q=1n4007&start=0&limit=10 If such a diode is not installed, just beware the LED might stop working.

Keep up the good work :)
Welcome to the friendlier side of internet crazy :)
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Apparently I was sleeping while I fixing injection pins :) I did in fact break status pins.

I believe that now we should have both status LEDs/pins and injection pins working properly - they do on my desk. Please take latest version and tell what is the issue with Tuner Studio again? Are you using 38400 speed in TS?
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
AndreyB
Site Admin
Posts: 12800
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: Mitsubishi 4G63 and 4G92

Post by AndreyB »

Tambralinga wrote:The stm32 is lack when I burn some value in Tuning Studio.
Yes, I see this. I've created a ticket for look into this - https://sourceforge.net/p/rusefi/tickets/77/
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Post Reply