[rusEfi] Sand drag Cherokee with 2JZ GTE VVTI #24

What engine are you torturing? Is it inside some car?
porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Sand drag Cherokee with 2JZ GTE VVTI #24

Post by porelmundo » Fri Jul 15, 2016 2:27 pm

My truck is a 1990 Jeep Cherokee with a 2JZ VVTI engine, the truck is running base on a MS3 with the VVTI support, Im running all crazy stuff you can imagine for a sand drag vehicle.
We do rally cross with it but also drag racing so i change everything and only that is left from Jeep is the body, if someone is interested on the setup please ask.
The primary objective of this project is to replace the ECU that im using right now with a Rusefi to prove the capabilities and the limits of rusefi design and push it forward for future projects that coming soon.
I already have the hardware and because the truck is already wire it suppose to be running in no time so keep reading because this is going to be fast and easy if i have no issues.
Lets see if my project inspire others projects and change others mind, no more generic.

Regards

Rob

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Fri Jul 15, 2016 11:00 pm

That's how 155 TDC offset from synchronization point look like, does this look right?
Attachments
screenshot.png
screenshot.png (33.78 KiB) Viewed 3812 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Fri Jul 15, 2016 11:36 pm

If green line represent TDC thats correct

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Sun Jul 17, 2016 4:19 am

Everything is ready for first test on the truck, I have timing and fuel tables compatible, so i know it will start, if start easy same day i will drive it and report back. I prepare a patch cables to be attached to my existing connectors, not because i dont want to cut them and transform it completely to rusefi, is because this engines get flood very easy, and if i have the capabilities to connect back the crap MS3 back and start it and cleen the engine, if start i will cut the connectors and declare a RUSEFI victory!!!!!

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Sun Jul 17, 2016 5:03 am

porelmundo wrote:this engines get flood very easy, and if i have the capabilities to connect back the crap MS3 back and start it and cleen the engine
rusEif has "cylinder cleanup" mode - that's if you crank with full throttle fuel is cut. You have to enable this once you have TPS calibrated, it's off by default to reduce first start errors.

Looking forward!
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Wed Jul 20, 2016 3:44 am

UFFFF!!! What a day, been working with a lot of stuff today, i dont know where to start, but i will say that first of all RUSEFI is running on a 2JZGTE VVTI!!!!
after fixing a lot of stuff making this rat nest of patching cable so i dont need to cut the existing connectors of the MS3 just in case i need to clean the engine with the existing installation and thanks because
it was a good decision, not because rusefi will be hard to start a engine is because i do so much test and bad installations in the past that put me really to work.
First of all, after jumping the outputs with 0 ohms resistors and install them in the wrong position and solder it at the correct location then try the crank sensor signal that it was dead, looks like the max9926 crank
output is not working, so i change the set up to use the crank trough the cam input and configure it correctly in TS, the only problem that set in up for waste spark on TS can be a little confusing and i will explain later
because is something that probably we need to work to make it friendly. Good part is that i have base maps that i can import the tables to TS because is compatible with MS tables. Next i go back and try to start the truck and for my surprise start right up but on 4 cylinders, I play a little with all this waste spark configuration with no luck but i had and other situation, looks like the wiring that i do 10 years ago had some issues so things need to be corrected before i test something else. The grounds are very important, and by those days 10 years ago MS practice was to put all grounds together and works by those days, now that we have this new a lot much better circuit conditioners the want grounds not shared with common grounds, so rewiring was a mess you can imagine. After that i connect again and everything was perfect. But wait i still have the coil that was missing? yeah after some test and some TS changes i found that a jumper from a coil was missing, El ruso told me but i miss that one. I install the jumper but is to late already to bother the neighborhood at midnight so i decide to call for today and declare a success. Photos and Videos to come.

Sorry if i bored someone with all my story.

Rob

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Wed Jul 20, 2016 3:53 am

The board you have has a brand new max9926 I've install to replace the burned out one, I've also destroyed some of the vias on the input side while replacing the connector. I think I've tested it but if anything is wrong with this board there is a good chance that the issue is with the signal not even getting to max9926 or GND side of the input not getting to max9926. Since one channel work can you test continuity of same everything just on the other channel? We need 2nd VR for the cam sensor to get VVTi running.
porelmundo wrote:the only problem that set in up for waste spark on TS can be a little confusing and i will explain later
because is something that probably we need to work to make it friendly.
Current hints for these fields are
bit twoWireBatchInjection;+This is needed if batched injection and individual injector wiring
bit useOnlyRisingEdgeForTrigger;+VR sensors are only precise on rising front
bit twoWireBatchIgnition;+This is needed if batched igniton (waster spark) and individual coil wiring
What would be a better way to explain this "two wire" thing?
porelmundo wrote:Photos and Videos to come.
Looking forward!!! Please post your CurrentTune.msq also!
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Wed Jul 20, 2016 4:17 am

The board you have has a brand new max9926 I've install to replace the burned out one, I've also destroyed some of the vias on the input side while replacing the connector. I think I've tested it but if anything is wrong with this board there is a good chance that the issue is with the signal not even getting to max9926 or GND side of the input not getting to max9926. Since one channel work can you test continuity of same everything just on the other channel? We need 2nd VR for the cam sensor to get VVTi running.
Found the problem, ground to the pull down.

Thanks

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Wed Jul 20, 2016 4:58 pm

Ok i found a bug in the code, I'm using wasted spark setup, that means that i only have 3 coils with double post in my 6 cylinder. In TS if i set the two wire thing false that mean to be configured then only work on two channels when 3 are need it, like when you set the number of cylinders don't change that code for 4 to 6, i don't know if i express the situation well.

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Wed Jul 20, 2016 5:07 pm

Some parameter changes require save&reboot, cylinder count could be one of them

Can you attach an invalid engine sniffer image? enable self_stimulation is the command to play with it on a bench
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Wed Jul 20, 2016 7:38 pm

Well i found it, when you selecting waste spark, the ignition pin to use is 1-3-5 and no 1-2-3 as i had configure. engine start and do idle but is not sound correctly. I will keep reporting.
we need to set up TS so when you select options like this the none use ones block. I will help do some guide later. People going to start hate me already with so much comment hahahaha

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Wed Jul 20, 2016 9:50 pm

porelmundo wrote:we need to set up TS so when you select options like this the none use ones block.
good idea! https://sourceforge.net/p/rusefi/tickets/303/
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Thu Jul 21, 2016 2:11 am

Done
Attachments
screenshot.png
screenshot.png (34.27 KiB) Viewed 3740 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Thu Jul 21, 2016 2:14 am

Now, what we was looking for: IS working perfect now, i think is revving much by far better than with the ms3, idle is good and rev OK, i had some trouble with the coil drivers, look like one output was not working properly and i switch to another and thats it. I'm really impress about all this!! things to be consider:

1- Fan control, a conditions need to be added provably tied to the cranking RPM or by user setting: you dont want the fan to comes on when you put the key on, it draw a lot of amps for cranking, people will say that want to cool down the engine with the engine off but is not a good practice. (temperature > a and RPM > b turn on Fan).

2- there is some times when you turn the key on and any of the Coils driver fire, happens when you reboot changing configurations but happens also on regular key on, need some kind of delay when turn the key on.
If the engine still have fuel in the cylinders is going to detonate (happens to me some times)

3- i want to understand how the VE tables is working, i was trying to lean the engine at idle because is excessive rich at idle but i went out to 0 and the engine still on with just minor change of AFR. don't know but AFR authority is 0 so there is some other variable that is putting gas on my setup. numbers on zero and working perfect at idle, rev up and die so is only at idle. I have no IAC so is neither that.

4- i would change some names on TS to make it more universal as you say.

5- Ignition air temperature correction. are those numbers ignition degrees to add or subtract?

Whell that is all that i remeber now but i know that many other things will come to my mind soon.
Here is my MSQ for those who want to take a look dont follow the outputs pins, after all MS3 work differently on this and i program it accordingly for what i have so i dont need to move cables around, fell free to ask why or for what, after all i'm just learning too.
Attachments
First start.msq
(122.66 KiB) Downloaded 148 times

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Thu Jul 21, 2016 2:17 am

porelmundo wrote:Now, what we was looking for: IS working perfect now
VIDEO video VIDEO video VIDEO?! :)
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Thu Jul 21, 2016 2:27 am

porelmundo wrote:1- Fan control, a conditions need to be added provably tied to the cranking RPM or by user setting: you dont want the fan to comes on when you put the key on, it draw a lot of amps for cranking, people will say that want to cool down the engine with the engine off but is not a good practice. (temperature > a and RPM > b turn on Fan).
Gotcha, just created https://sourceforge.net/p/rusefi/tickets/304/
porelmundo wrote: 2- there is some times when you turn the key on and any of the Coils driver fire, happens when you reboot changing configurations but happens also on regular key on, need some kind of delay when turn the key on.
If the engine still have fuel in the cylinders is going to detonate (happens to me some times)
could be hardware issue see http://rusefi.com/forum/viewtopic.php?f ... 240#p19442
porelmundo wrote: 3- i want to understand how the VE tables is working, i was trying to lean the engine at idle because is excessive rich at idle but i went out to 0 and the engine still on with just minor change of AFR. don't know but AFR authority is 0 so there is some other variable that is putting gas on my setup. numbers on zero and working perfect at idle, rev up and die so is only at idle. I have no IAC so is neither that.
Have you seen the 'formulas' tab in rusEfi console? Default injector lag is 1ms plus there is VBatt injector lag correction so if your VBatt is not right you will get a lot of injection just for the lag
porelmundo wrote: 4- i would change some names on TS to make it more universal as you say.
please be more specific! there is https://sourceforge.net/p/rusefi/tickets/273/

porelmundo wrote: 5- Ignition air temperature correction. are those numbers ignition degrees to add or subtract?
float result = advanceMap.getValue((float) rpm, engineLoad) + iatCorrection
value is added to the advance
porelmundo wrote:fell free to ask why or for what, after all i'm just learning too.
why did not you use twoWireBatchIgnition?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Thu Jul 21, 2016 3:12 am

Yeah i will study that, more test need to be done to be sure.
Have you seen the 'formulas' tab in rusEfi console? Default injector lag is 1ms plus there is VBatt injector lag correction so if your VBatt is not right you will get a lot of injection just for the lag
Right why i dont think about that, need to calibrate VBatt tomorrow.
please be more specific! there is https://sourceforge.net/p/rusefi/tickets/273/
General stuff like, injector dead time, but there is a bunch of stuff i will comment about this later.
float result = advanceMap.getValue((float) rpm, engineLoad) + iatCorrection
value is added to the advance
Understand that perfect, but are those numbers time degrees?
why did not you use twoWireBatchIgnition?
Because the 2JZGTE VVTI JDM only have 3 coils, and why 3 coils? is what i was talking to you, it can start on waste spark and semi sequential injection and sync with the cam and change to sequential. I have the code i will post it later. It will be a long discussion about the sync of this engine and is related to the VVTI as well.

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Thu Jul 21, 2016 8:24 pm

porelmundo wrote:
float result = advanceMap.getValue((float) rpm, engineLoad) + iatCorrection
value is added to the advance
Understand that perfect, but are those numbers time degrees?
the values and timing degrees and axis are intake temperature and RPM (not engine load - just fixed axis name)
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by porelmundo » Fri Jul 22, 2016 1:02 am

Report for today afternoon:
Calibrate sensors; IAT(GM), O2(innovate), TPS(Nissan), Coolant(Toyota) also put injector dead times VS voltage(table) Batt. Everything is on parameters, but still not correcting at idle, if your VE table is zero taking all
kinds of possible corrections, still some big pulse. I understand the speed density formula, but is not this proportional to the 0? I'm provably need to measure the output with a oscilloscope but as the VE is 0 the still formula correction that is to much for my engine. or i'm receiving more injections per cycle than need it, can be all the waste spark thing. Also the big thing is that the formula is missing the required fuel calc, only work if i move from idle to more than 3000RPM and around 80kpa. I change to alpha-n and that table is working properly but again some correction is not letting me go under 2ms. The VE table at TS say "%" need to be map load KPA, also those fuel coefficients and hacks have me something, that need to be constants, adding a stoichiometric setting is not a bad idea . I'm out of ideas. go to rest for the weekend.
Attachments
2016-07-21_20_26rpm_1199_maf_NaN.png
2016-07-21_20_26rpm_1199_maf_NaN.png (37.46 KiB) Viewed 3701 times
CurrentTune.msq
(121.79 KiB) Downloaded 99 times

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Fri Jul 22, 2016 1:07 am

too much for me to digest simultaniously, how do we address problems one at a time?

do i understand right that formula tab is not functioning properly for you? Or some info is missing or smth does not add up?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI

Post by russian » Fri Jul 22, 2016 1:08 am

ps: maybe post some logs if those indicate any issues?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by porelmundo » Fri Jul 22, 2016 1:16 am

Yes, and i'm sorry i will try to be more organize in the future to many ideas in my head hahahaha :lol:
Yeah the formula is missing the required fuel calculation ( table follow)

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by porelmundo » Sat Jul 23, 2016 12:40 am

is this correct?

PW = DT + (ReqFuel * MAP * Stoich/AFRtarget * VE[RPM,MAP] * AirDen * BaroCor * corrections)

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by russian » Sat Jul 23, 2016 12:43 am

https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by porelmundo » Sat Jul 23, 2016 2:47 am

After looking your formula, I think i found the issue but is to late night to try it now, i will report tomorrow.

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by russian » Sun Jul 24, 2016 1:12 am

Looks like I've just fixed a bug which was affecting you - https://sourceforge.net/p/rusefi/code/1 ... e841:10276

This defect was not visible for 4 cylinder engines with wasted fuel but it is affecting engine with less or more cylinders, like yours.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by porelmundo » Sun Jul 24, 2016 10:25 pm

Yeah, thanks cos i check everything possible, need to go back and test again.

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by porelmundo » Sun Jul 24, 2016 11:15 pm

nop still the same situation, too rich at idle.

User avatar
russian
Site Admin
Posts: 9518
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by russian » Sun Jul 24, 2016 11:20 pm

can u post a log and the tune? Maybe an image of formula tab also?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

porelmundo
contributor
contributor
Posts: 52
Joined: Tue Apr 26, 2016 1:15 am

Re: Sand drag Cherokee with 2JZ GTE VVTI #24

Post by porelmundo » Mon Jul 25, 2016 12:03 am

The console math, working on the log, i found something else but i comment when i post the log.
Attachments
math.jpg
math.jpg (169.57 KiB) Viewed 3631 times

Post Reply