[rusEfi] red 2003 VVT test mule Miata NB2 #27

What engine are you torturing? Is it inside some car?
User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

But even with not eBay coils I have crank signal disappearing if coils are hooked up :(

Here you can compare second line signal with both coils disconnected VS one coil connected.
Attachments
cranking_signal_losses_one_coil.png
cranking_signal_losses_one_coil.png (68.17 KiB) Viewed 6298 times
cranking_no_coils.png
cranking_no_coils.png (43.63 KiB) Viewed 6298 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

puff
contributor
contributor
Posts: 2809
Joined: Mon Nov 11, 2013 11:28 am
Location: Moskau

Re: red 2003 VVT test mule Miata NB2 #27

Post by puff »

hm. shall I try cranking my oldrusty rover without a coil attached?
do you think it's just affecting the usb connection, or the whole thing?

puff
contributor
contributor
Posts: 2809
Joined: Mon Nov 11, 2013 11:28 am
Location: Moskau

Re: red 2003 VVT test mule Miata NB2 #27

Post by puff »

one more thing, I've heard that installing a large capacitor across the coil's power lines help (although I don't understand why it should help)

User avatar
kb1gtt
contributor
contributor
Posts: 3643
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA

Re: red 2003 VVT test mule Miata NB2 #27

Post by kb1gtt »

Yeah, it's likely a huge inrush, causing the GND voltage to spike. The huge cap on the supply simply provides allot of HF energy locally, so you don't have that energy on the MCU GND.
Welcome to the friendlier side of internet crazy :)

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

After 24 hours of head banging I've noticed that cranking RPM without coils was 480 RPM. 480 RPM is not the right cranking RPM of my car, it should be 240 RPM...

Now I am thinking that there were multiple issues introduced at different points in time - loss of GND during the catastrophic event, bad replacement coil was not helping and on top of that wrongly "refactored" VVT or trigger code has messed up engine cycle :(

Test mule now starts reliably on MRE 0.3 - if 2019 Xmas firmware is used AND there is a jumper cable between engine block and battery.

Also note how on this picture VVT fronts are inverted comparing with 2019-10-21_rpm_1102_Frankenso_MAX9926_5K_pull_ups.png in first post of this thread.

I will go have some cognac.
Attachments
2020-02-13_rpm_809_MRE_0_3_xmax_branch_jumper_GND_cable.png
2020-02-13_rpm_809_MRE_0_3_xmax_branch_jumper_GND_cable.png (40.25 KiB) Viewed 6281 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

NB2 miata has MAF as primary load sensor, but it also has "EGR boost sensor". Could this EGR boost sensor be used as load sensor?

Looks like there is a solenoid between this EGR boost sensor and intake? Not sure.

See also https://forum.miata.net/vb/showthread.php?t=590218

PS: and second question: stock MAF reports +12 analog voltage does it? What would be a good voltage divider value to convert it into 5v signal?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

stefanst
contributor
contributor
Posts: 606
Joined: Wed Feb 17, 2016 12:24 am
Location: USA 08530

Re: red 2003 VVT test mule Miata NB2 #27

Post by stefanst »

The NB2 does have a "boost sensor". NB1 has it as well, as far as I know. I don't remember how the air-side of this sensor is connected though.
If I understand correctly, It is used to ensure that the EGR solenoid is opening correctly and exhaust gas makes it into the intake. The assumption is that when the EGR valve opens we get an increase in MAP. So, in theory, this sensor is a pressure sensor and should cover at least a good part of the operating range of the engine. I do remember somebody who wanted to put an aftermarket ECU in his car, but couldn't use any additional sensors due to class restrictions, planning to use that sensor as an ECU MAP sensor. I don't think we ever had any published result.

Suggestion: Run the engine at different loads and measure the signal. If it's a simple voltage signal, it shouldn't take too long.

scramblr
Posts: 63
Joined: Fri Sep 20, 2019 4:57 pm

Re: red 2003 VVT test mule Miata NB2 #27

Post by scramblr »

My undersanding is the same.
I believe the "EGR boost sensors" is ultimately a simple pressure sensor, that most likely limits out at 1 bar (atmosphere).
It should be reading the manifold pressure like any other MAP sensor. It just isn't used as the primary load sensor with the stock controller.

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Latest firmware, Frankenso hardware.
set engine_type 47

Battery coefficient 8.80 looks to match DMM better but maybe it affects MAP calibration negatively? Probably good enough for this test.

Looks like no TPS signal, no idea why but should make no difference for this test?

Cold engine

Logic analyzer shows pretty broken trigger signal while cranking. That's with a jumper cable between VVT solenoid on top of the engine and battery negative terminal in the trunk.

Attachments
Logic_JD0GugmZQY.png
Logic_JD0GugmZQY.png (105.95 KiB) Viewed 3721 times
Frankeno_20200410_164419.jpg
Frankeno_20200410_164419.jpg (479.45 KiB) Viewed 3721 times
Frankeno_20200410_164410.jpg
Frankeno_20200410_164410.jpg (637 KiB) Viewed 3721 times
2020_apr10_cranking_TunerStudioDebugPackage.zip
(840.09 KiB) Downloaded 31 times
2020_apr10_cranking.zip
logic analyzer data
(66.12 KiB) Downloaded 29 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

For comparison here is microRusEfi crank line - more or less same signal drama?
Attachments
2020_apr10_cranking_microRusEfi.7z
(3.15 KiB) Downloaded 32 times
Logic_nhNSMbZ9EF.png
Logic_nhNSMbZ9EF.png (81.4 KiB) Viewed 3718 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Just a recap:

we were suspending "ground issues" for some time. Things are really bad without a jumper cable from VVT valve to battery, and somewhat better with the jumper cable.

I've just added a proper ground strap from OEM body point to non-OEM engine point (OEM engine is hard to reach). I now have three grounds between engine and body - jumper cable, original strap, extra strap.

Can we please look somewhere else now?...
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Frankenso uses 4.99K pull-ups and MRE probably uses a 1.5K pull-up
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

stefanst
contributor
contributor
Posts: 606
Joined: Wed Feb 17, 2016 12:24 am
Location: USA 08530

Re: red 2003 VVT test mule Miata NB2 #27

Post by stefanst »

It may be a voltage issue. NB Miatas have a weird signal-inversion behavior during cranking, especially when cranking more slowly. Cranking drops the voltage and that may cause some funkiness with the sensor. Try a bigger/newer battery? If one is not at hand, run separate power for the sensors (12V wall-wart should do) and use the battery to just crank.

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Battery is few months old but I suspect I could have a drain. I am very very close to installing a kill switch next to the battery.

Rigol has started to pay for itself: VVT PWM noise is very visible on this not running engine with pretty much discharged battery. Now I need to plug battery charger extension cord in and give it a couple of hours.

At the moment VVT uses FSIO aux PWM generation and that thing does not turn itself off with stopped engine. VVT will be unplugged for now.
Attachments
stopped_engine_VVT_unplugged.png
stopped_engine_VVT_unplugged.png (94.33 KiB) Viewed 3630 times
stopped_engine_VVT_noise.png
stopped_engine_VVT_noise.png (108.03 KiB) Viewed 3630 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Some composite logs gathered so far
Attachments
unhappy_composite_DataLogs.zip
(12.04 KiB) Downloaded 25 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Super long adapter harness may be adding enough inductance to be a problem.

Adding a shortish (2') alligator clip from Frankenso ground to intake reduces spike from VVT turn on/off by an order of magnitude. (down to ~0.5v peak-to-peak)

To be continued.
Attachments
VVT_running_14ft_aligator_wire_between_engine_and_ECU.png
VVT_running_14ft_aligator_wire_between_engine_and_ECU.png (52.15 KiB) Viewed 3601 times
VVT_running_4ft_aligator_wire_between_engine_and_ECU.png
VVT_running_4ft_aligator_wire_between_engine_and_ECU.png (50.85 KiB) Viewed 3601 times
VVT_running_2ft_aligator_wire_between_engine_and_ECU.png
VVT_running_2ft_aligator_wire_between_engine_and_ECU.png (90.6 KiB) Viewed 3601 times
miata_2003_ecu_GND_goes_to_intake_close_to_TB.jpg
miata_2003_ecu_GND_goes_to_intake_close_to_TB.jpg (513.27 KiB) Viewed 3601 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Things have improved from "nearly impossible to start" into "starting is reliably poor", only 8 out of 21 attempts were successful

Two things have helped:
1) Both crank and cam sensors of this NB2 should be considered VR for software decoding and we shall rely only on rising fronts. Still Hall-style hardware decoding with pull-up resistors.
2) my tune was not using idle solenoid due to a configuration mistake. this is now improved under https://github.com/rusefi/rusefi/issues/1332

Still look for better starting obviously. Tune, sensor and composite logs attached.

Attachments
NB2 kind of starts sometimes logs.zip
(525.59 KiB) Downloaded 22 times
NB2 kind of starts sometimes TunerStudioDebugPackage.zip
(832.92 KiB) Downloaded 26 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

As an experiment we've switched to CAM sensor only. With attached tune I can start every time! Minor improvements to idle air were made.

So it looks like crank+vvt trigger decoding is part of my starting issue.
Attachments
NB2 running on cam sensor only TunerStudioDebugPackage.zip
(1.69 MiB) Downloaded 19 times
NB2 running on cam sensor only 2020-04-20_23.36.32.mlg.zip
(411.53 KiB) Downloaded 26 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

Crazy Striker
kit assembler
Posts: 137
Joined: Wed Aug 08, 2018 6:05 pm
Location: Brest, Britanny, France

Re: red 2003 VVT test mule Miata NB2 #27

Post by Crazy Striker »

For referencing purposes so that nothng get lost, here is the MAF transfer tab for 94+ miata. I'll run it but just to monitor flow, nothing more.

Cheers

Gwendal
Attachments
image.png
image.png (81.78 KiB) Viewed 3413 times

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

the way rusEfi was handing NB2 special symmetrical crank was one of the reasons of unreliable cranking experience on this car. https://github.com/rusefi/rusefi/issues/1278 code change has addressed this issue.

Attachments
VVT miata trying to crank with random phase fixed TunerStudioDebugPackage.zip
(3.44 MiB) Downloaded 25 times
VVT miata trying to crank with random phase fixed DataLogs.zip
(289.5 KiB) Downloaded 20 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Crazy Striker wrote:
Wed Apr 22, 2020 1:42 pm
For referencing purposes so that nothng get lost, here is the MAF transfer tab for 94+ miata. I'll run it but just to monitor flow, nothing more.
Thank you, this is now part of NB2 default tune.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

A very quick run with speed density fuel and MAF recording
Attachments
2020-05-02_speed_density_with_MAF_logging.zip
(45.17 KiB) Downloaded 24 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Crazy Striker wrote:
Wed Apr 22, 2020 1:42 pm
For referencing purposes so that nothng get lost, here is the MAF transfer tab for 94+ miata.
Is https://forum.miata.net/vb/showthread.php?t=486064 the source of this data? This looks like NA miata.
NA and NB MAF sensors seem to be different at least in terms of IAT sensor internal vs external. No idea if same transfer function or not.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Just double-checked that OEM ECU has 1K between pins 4X "MAF" and 4O "Sensor GND" yet the MAF function we find on the internet does not produce reasonable readings for rusEFI Frankenso with a 1K pull-down.

As a work-around I took a known 0280218004 MAF sensor - that one needs both +5v and +12v supply but at least output is voltage without any pull-down magic. And the car is running!

Next step would be to guesstimate Miata NB MAF based on 0280218004 data. One of the logs show 0280218004 voltage in "oil pressure" column while running on MAP, the other one shows running on 0280218004.
Attachments
DataLogs_0280218004.zip
(372.16 KiB) Downloaded 19 times
miata_with_0280218004.jpg
miata_with_0280218004.jpg (587.79 KiB) Viewed 3175 times
Bosch_0280218004_MAF_function.xlsx
(13.91 KiB) Downloaded 24 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Another day and fresh drama to chase!

TunerStudio via TTL disconnects on engine start, with two different HW setups:
1) MRE72+MRE+Bluetooth HC-06 @ 38K
2) Frankenso+Prolific USB-to-Serial, hard-wired, at 115K

Frankenso log & comms log attached.
Attachments
TTL DataLogs and comms.zip
(76.78 KiB) Downloaded 18 times
Frankenso_TTL.jpg
Frankenso_TTL.jpg (631.98 KiB) Viewed 3056 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Digital multi-meter shows 1K pull-down on MAF signal line inside OEM ECU and a 5.5K resistance to +5v? Shipping OEM 279721-1201 PCB to @mck1117 for him to do some poking.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Looking at this schematics I was hoping to see either 2O or 2M wires but not both in my harness? My car has both wires on the "2" ECU plug. I was really hoping 2O would be a pin available for rusEFI purposes :(
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

I have a very beautiful test mule!

Took it on a very lean field trip. MAF sensor was driving, MAP was just riding along, WBO was... concurned.
Attachments
TunerStudioDebugPackage.zip
(1.05 MiB) Downloaded 10 times
2020-05-17_lean_maf_trip.mlg.zip
(483.19 KiB) Downloaded 11 times
20200517_201414.jpg
20200517_201414.jpg (811.97 KiB) Viewed 1056 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Emil says a bypass hose would be needed to use OEM pressure sensor to run the engine.
Attachments
image_from_ios.jpg
image_from_ios.jpg (2.91 MiB) Viewed 980 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10490
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: red 2003 VVT test mule Miata NB2 #27

Post by AndreyB »

Ha, there is a crazy idea to actually drive that EGR solenoid since we have outputs! That would be low side pin 3D.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

Post Reply