86 Toyota MR2 AW11 + 4A-GE small port

What engine are you torturing? Is it inside some car?
Post Reply
pk386
Posts: 10
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS
Soldering skill: yes
Coding skill?: yes

86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 » Mon Mar 11, 2019 2:56 am

Evening from Mississippi!

My 86 MR2 Has been an on going project for the past 8 or so years.
It's now time to get rid of the 1980s ECU and step up to something more modern :D

Goals for this project are:
1) Learn
2) Update the ECM / Wiring harness
3) Make the car / Engine electrical more manageable and easier to service
4) Upgrade to coil-on-plug Ignition
5) Upgrade the injectors to a more modern variant.
6) Delete the 'flappy door' MAF.

About the engine
- 4A-GE 7 rib block,
- Rebuilt stock bottom end with / 5-10K miles
- ARP head studs
- Supertech MLS Head Gasket
- Piston rings gapped at widest factory tolerance (For boost)
- Small Port head
- Mild port on the intake
- Stock Cams
- Compression ratio ~9:1

Long term goals are 150-200 HP at the crank.
Going to stay NA for a while but plan on running a Small Turbo one day.

Once I get some experience under my belt I hope to contribute more to the project as time allows.


Board booting:
Annotation 2019-03-10 212829.jpg
Annotation 2019-03-10 212829.jpg (149.71 KiB) Viewed 439 times
Car:
car  2019-03-10 213916.jpg
car 2019-03-10 213916.jpg (97.07 KiB) Viewed 439 times
Engine:
Engine.jpg
Engine.jpg (243.86 KiB) Viewed 439 times
Crank trigger setup.
crank 2019-03-10 214604.jpg
crank 2019-03-10 214604.jpg (188.36 KiB) Viewed 439 times

User avatar
russian
Site Admin
Posts: 9526
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by russian » Mon Mar 11, 2019 3:04 am

Welcome!

Things are too clean and too assembled :) Trigger looks like 36/2 or 36/3 or something similar? Is there a cam sensor anywhere?

Do you have JP04 and JP05 between MAx9926 and stm32?

When do you plan to crank the engine with this ECU? :)
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
kb1gtt
contributor
contributor
Posts: 3410
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA
Contact:

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by kb1gtt » Mon Mar 11, 2019 9:16 am

Welcome along. Looks like some nice progress.
Welcome to the friendlier side of internet crazy :)

pk386
Posts: 10
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS
Soldering skill: yes
Coding skill?: yes

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 » Tue Mar 12, 2019 2:08 am

russian wrote:
Mon Mar 11, 2019 3:04 am
Things are too clean and too assembled :) Trigger looks like 36/2 or 36/3 or something similar? Is there a cam sensor anywhere?

Do you have JP04 and JP05 between MAx9926 and stm32?

When do you plan to crank the engine with this ECU? :)
Yes Nissan instills 5S in the work place some of it carries over to personal life :)
https://en.wikipedia.org/wiki/5S_(methodology)

Not Yet But I will install them. I assume that is a common mistake People Make?

Probably Looking at sometime in July. Lots of little things to do between now and then

Got an ECU Case on Sunday but it was from a '92 Camry... (and NO the Frankenso Does not fit the 92 case, PN: 89661-06061, Mounting holes for the PCB don't line up)

So I went back after work today and got a case from a 95' Camry [PN: 89661-06270]
Had to cut out one corner but it fits now.

The arrow shows where I had to cut.
trim2.png
trim2.png (703.4 KiB) Viewed 417 times
Close up of the cut:
trim.jpg
trim.jpg (81.66 KiB) Viewed 417 times

The 3.5mm Head Phone Jack will have to be removed and a hole cut for the LCD.
Z-height.png
Z-height.png (777.45 KiB) Viewed 417 times

pk386
Posts: 10
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS
Soldering skill: yes
Coding skill?: yes

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 » Tue Mar 12, 2019 2:24 am

Got some better Photos of the trigger wheel.

The trigger wheel is from a 7A/4A-FE Engine from a '96 Corolla
tw2.jpg
tw2.jpg (39.66 KiB) Viewed 416 times
tw1.jpg
tw1.jpg (23.82 KiB) Viewed 416 times
I haven't welded the Trigger wheel to the Timing gear so If any one has advice on how to Clock them it would be appreciated.

What I have in the pictures is it clocked the same relationship that it had with the original timing gear.

User avatar
russian
Site Admin
Posts: 9526
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by russian » Tue Mar 12, 2019 2:34 am

That corner of the LCD I just usually cut and most of my LCDs are mounted with only three stand offs.

The 3.5mm jack I usually yank out since it does not clear vertically anyway.
pk386 wrote:
Tue Mar 12, 2019 2:24 am
I haven't welded the Trigger wheel to the Timing gear so If any one has advice on how to Clock them it would be appreciated.
Why weld anything not OEM? Why not use OEM trigger and OEM sensor?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

theflyingdutchp
Posts: 91
Joined: Wed May 18, 2016 11:03 pm

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by theflyingdutchp » Sat Mar 16, 2019 1:15 am

If this has the Toyota VAST ignition (with the two wheels in the distributor) it might work with that. I've been meaning to see if I can get synchronization but life is getting in the way.

Otherwise, the RusEFI wiki supports a "Global Trigger Angle Offset" mentioned here: https://rusefi.com/wiki/index.php?title ... C_position
If @ can confirm that its currently working, then I don't see why the clocking of your position sensor will matter too much.

pk386
Posts: 10
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS
Soldering skill: yes
Coding skill?: yes

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 » Sat Mar 16, 2019 7:01 pm

theflyingdutchp wrote:
Sat Mar 16, 2019 1:15 am
If this has the Toyota VAST ignition (with the two wheels in the distributor) it might work with that. I've been meaning to see if I can get synchronization but life is getting in the way.

Otherwise, the RusEFI wiki supports a "Global Trigger Angle Offset" mentioned here: https://rusefi.com/wiki/index.php?title ... C_position
If @ can confirm that its currently working, then I don't see why the clocking of your position sensor will matter too much.

That's good to know.

Yes it does have the VAST ignition, (Which to be honest is a brilliant design with the limited technology available at the time.)
I plan on converting to coil on plug for better control of ign timing.

For now I plan on putting the stock distributor back in for using the single trigger as a sync pulse. I'd like to use something more compact in the future to clean up the engine bay.
trigger.jpg
trigger.jpg (89.39 KiB) Viewed 360 times
(Picture borrowed from this Link:
https://www.toymods.org.au/forums/threa ... or-Rebuild)

User avatar
russian
Site Admin
Posts: 9526
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by russian » Sat Mar 16, 2019 9:08 pm

Global trigger offset works for sure
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

pk386
Posts: 10
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS
Soldering skill: yes
Coding skill?: yes

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 » Fri Mar 22, 2019 11:58 pm

Ok so I got some time to spend with the board.

I have two questions.

1) I tried the injector test with the console.... should the indicator LEDs light up or is there a 5V jumper I am missing?


2) How is the Joy stick mapped out?
I see this after moving the Joy stick in all 4 directions + center.

Code: Select all

2019-03-22 18_53: EngineState: confirmation_joystickinfo:12
2019-03-22 18_53: EngineState: total 7 center=4@PC8
2019-03-22 18_53: EngineState: a=2@PD10
2019-03-22 18_53: EngineState: b=0@NONE
2019-03-22 18_53: EngineState: c=0@NONE
2019-03-22 18_53: EngineState: d=1@PD11
I'm not sure If something is wrong with the Joy stick but it seems like
(Directions relative to the text of the LCD)
(Right) = Next (or down the list)
(Left) = Enter
(center) = Go back to main screen
(Down) = No function.
(UP) = No function


Thanks in advance, Just trying to get a feel for how things work before I start laying out the harness and the I/O

User avatar
russian
Site Admin
Posts: 9526
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by russian » Sat Mar 23, 2019 12:01 am

2) yes, Joy stick is wired weirdly. Looks like everything on your board, what I see is expected. Ignore Joy stick for now

1) no jumpers on primary low side drivers and LEDs. Something is not right here. Pictures of both sides of the board maybe? Do you have a beeping multimeter? It would beep since it would ground outputs.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

pk386
Posts: 10
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS
Soldering skill: yes
Coding skill?: yes

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 » Sat Mar 23, 2019 1:17 am

2)... DOH, I forgot I didn't put the LED's on the low side, LOL :roll:

I also realised that In "Injector #1" in the console is NOT INJ-01_2 on the Frankenso board. :?

(I noticed the console Triggering PB9 in the console window and started tracing the schematics to INJ-09 on the Schematics)

Now I get 3 Ticks from my Multimeter when I hit test "Injector#1" :D

pk386
Posts: 10
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS
Soldering skill: yes
Coding skill?: yes

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 » Sat Apr 13, 2019 1:00 pm

Small Update:

more painted bits on the engine:
1.jpg
1.jpg (292.88 KiB) Viewed 220 times
engine harness deconstruction and labeling:
2.jpg
2.jpg (212.58 KiB) Viewed 220 times

Post Reply