[Success Story] 86 Toyota MR2 AW11 + 4A-GE small port [Frankenso]

Your chance to introduce yourself and your vehicle
pk386
Posts: 36
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 »

OK Got the base timing set to 10deg BTDC

Put fuel to it and added 3 gallons of fresh gas.

I can get it to fire. But then the RPM's slowly tapers off and dies.
Fuel pressure is good at ~35psi. per factory spec.

it will idle at about 550 -> 600 RPMS for a few seconds If I do a fuel clear (WOT) and then crank it again.

I have my make shift IAC disconnected and I am relying on the factory IDLE air screw to idle. (I'll worry about IAC later)

Soo what next? I am at a loss.



Here are some videos:
https://photos.google.com/share/AF1QipO6ybQN9Y4dy5NwqzsRHJuz9JIfx3dmBU1pOAaBjAWqq6puDZBXJl66LrlgxSD1nA?key=cHB2N2VvVG81RWh0QkttMWxaeDNoa1dRV1l4bnhB

https://photos.google.com/share/AF1QipOJ9K2tLSLIce8olf02qiizDyCtrspBaU3-M9BFka-_Y34a1qL9KoWhIbh1W63tsQ?key=bGhaQmpUTGpNUTJja1J3Q3pWYzUzWUJjR2ZvRHln

Tune is located here:
https://rusefi.com/online/index.php?vehicleName=1986+MR2&user_id=909&sorts[uploadedMsq]=-1&sorts[uploadedLog]=-1

Log is located here:
https://rusefi.com/online/view.php?log=48
mck1117
running engine in first post
running engine in first post
Posts: 1338
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by mck1117 »

Looks like your fuel stoichiometric AFR is set to 0, and you probably want it at 14.7. I think we fall back to 14.7 if the value is invalid, but it's worth setting anyway.
image.png
image.png (22.31 KiB) Viewed 6428 times
mck1117
running engine in first post
running engine in first post
Posts: 1338
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by mck1117 »

I don't see anything particularly offensive in the log - but I see your VE looks pretty small. Have you tried adding/removing VE to try and find a spot it'll run? I'd add 5 ve, try a start, and repeat until you hit maybe 70%. Once you get it to run sustained (even poorly), just look at the wideband for which way the VE needs to go.
User avatar
AndreyB
Site Admin
Posts: 13029
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by AndreyB »

Wideband not reading on this log that's making us half-blind
image.png
image.png (85.78 KiB) Viewed 6423 times
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
User avatar
AndreyB
Site Admin
Posts: 13029
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by AndreyB »

Without WBO what's your process? How did you get VE values you have in the table?
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
mck1117
running engine in first post
running engine in first post
Posts: 1338
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by mck1117 »

AndreyB wrote:
Thu Oct 08, 2020 12:01 am
Wideband not reading on this log that's making us half-blind
2 seconds is not enough engine runtime for the wideband to be useful
pk386
Posts: 36
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 »

Yea the WBO is not connected yet. Just trying to get it to start and Idle.

The VE values were copied and pasted from another 4A-GE tune from a mega squirt.

I'll try the +/- 5% then crank method and see what I can get.

I know I need a WBO but wanted to see if I could get it to idle first.
(I have a brand new in the box AEM X-Series)
Does the CAN bus input work for this yet?
https://www.aemelectronics.com/products/wideband-uego-air-fuel-controllers/x-series-inline-wideband-uego-afr-controller
mck1117
running engine in first post
running engine in first post
Posts: 1338
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by mck1117 »

pk386 wrote:
Thu Oct 08, 2020 12:26 am
(I have a brand new in the box AEM X-Series)
Does the CAN bus input work for this yet?
https://www.aemelectronics.com/products/wideband-uego-air-fuel-controllers/x-series-inline-wideband-uego-afr-controller
yes - there's a setting on the EGO page to enable AEM X-Series wideband support. I've been using one for almost a year now.
pk386
Posts: 36
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 »

1) Using the following trigger settings I was able to get the cam pulse to show up in the logs.
- Had to INVERT the CAM sync pulse.
image.png
image.png (171.78 KiB) Viewed 6396 times
https://rusefi.com/online/view.php?msq=232

2) had to use TPS value instead of load.
(Goal is to get it on the map sensor.)
image.png
image.png (51.27 KiB) Viewed 6396 times


3) Video Of a stable Idle!
https://photos.app.goo.gl/xgfvhAcnPQfhrRKb8


- Now to get some coolant in it (Had a hole in one of the hoses) and check the thermal stability.
(coolant fans run independently of the ECM)

- double check the base timing at an idle RPM speed and get it dialed in 100%

- put exhaust on the car and weld in WBO bung.

- Work with you guys on getting sequential Injection and spark working :-)

- tune

- ????

- Profit
User avatar
AndreyB
Site Admin
Posts: 13029
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by AndreyB »

Please cover the ECU with something at some point soon :)

Congrats and please spread the word :)
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
mck1117
running engine in first post
running engine in first post
Posts: 1338
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by mck1117 »

Excellent! Speed density mode should work okay once your MAP sensor is behaving itself (which it looked like it was in the log, actually).
pk386
Posts: 36
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 »

LONG TIME NO UPDATE!

Sorry team I've been working on a HUGE automated ECM project for my work and haven't had time to work on my own ECM :cry:

Back to where I left off I had the Car up and running but I had a suspicion that my timing was off.
However none of this mattered because it was leaking oil from cam and crank seals and the water pump failed.

In the process of fixing the crank seal I broke my trigger wheel. :-(
I tried TIG welding it back together but no luck the sensor was no longer picking up one of the teeth....

SO FF to today. I have the parts to make another trigger wheel.

I started researching through the documentation and had a question...

on this page:
https://github.com/rusefi/rusefi/wiki/All-Supported-Triggers#how-this-works

The Green line = TDC #1

Does that mean :
A) TDC Between the Exhaust stroke -> Intake stroke
OR
B) TDC Between the compression stroke -> Power stroke


once I get the new wheel assembled I will get some trigger wheel shots and post up.
mck1117
running engine in first post
running engine in first post
Posts: 1338
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by mck1117 »

TDC#1 = end of compression, start of power, near when the spark happens.
pk386
Posts: 36
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 »

Wanted to get a quick update I have it running and idling!

https://photos.app.goo.gl/spXBn9854rpR7WLp7

(Yes I know the AFRs are lean :-) )

Now to the laundry list of things to do:
- Engine bay fan Controlled by ECM
- Make a set of DET-CANS or make an audio type knock sensor
- Get the AFR's dialed in.
- Get T-VIS working (Intake runner control)
- hundreds of other things left on the list.
pk386
Posts: 36
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 »

mck1117 wrote:
Fri May 07, 2021 10:26 pm
TDC#1 = end of compression, start of power, near when the spark happens.
BTW THANKS! Once I understood that every thing lined up on the trigger page.
pk386
Posts: 36
Joined: Fri Feb 08, 2019 11:12 pm
Location: Ridgeland, MS

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by pk386 »

Finally got around to getting the car running well enough to drive the car.

Did real good on a 30min drive to a car show.
Still lots of work to do. Stay tuned.
image.png
image.png (2.24 MiB) Viewed 3082 times
User avatar
AndreyB
Site Admin
Posts: 13029
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Github Username: rusefillc
Slack: Andrey B

Re: 86 Toyota MR2 AW11 + 4A-GE small port

Post by AndreyB »

pk386 wrote:
Sat Dec 04, 2021 11:35 pm
Did real good on a 30min drive to a car show.
Sounds like you are enjoying this thing :)
Very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions

Always looking for C/C++/Java/PHP developers! Please help us see https://rusefi.com/s/howtocontribute
Post Reply