[rusEfi] Nissan on Frankenso #47

What engine are you torturing? Is it inside some car?
filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Sun Apr 07, 2019 3:17 pm

It happened today in another discovery new board. I suspect this could be a problem with my TS project as I have not seen it before yesterday. As I said I noticed this happening after I got conflict for no reason in inputs. Previously I had changed an input to another and the discovery gave me the fatal error even if the input used was not occupied by anything else as far as I know.

I will uninstall the Tuner Studio and reprogram but if you could use my entire project in a simulator and see if MAP gauge drops when cranking.

Attached is my entire project. Try it.

UPDATE:

I went back 2 days and I am trying another TS project. The MAP value still drops to zero during crank and that maybe normal. The issue has not shown up yet. I suspect something got really corrupted on TS project 34 that I attached. I hope this issue does not show up anymore. If it does I will advise.
Attachments
MyCar34.zip
(2.93 MiB) Downloaded 11 times

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Sun Apr 07, 2019 4:25 pm

It starts to sound not like "engine was running and suddenly flash is corrupted" but more like "I was changing settings and with some settings ECU would get confused"

I see no point uninstalling TS.

I'd say
1) erase chip
2) flash latest firmware
3) create new TS project using latest project definition file

if you can break it again, please share what exactly you are doing to break it :)
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Sun Apr 07, 2019 6:15 pm

russian wrote:
Sun Apr 07, 2019 4:25 pm
It starts to sound not like "engine was running and suddenly flash is corrupted" but more like "I was changing settings and with some settings ECU would get confused"

I see no point uninstalling TS.

I'd say
1) erase chip
2) flash latest firmware
3) create new TS project using latest project definition file

if you can break it again, please share what exactly you are doing to break it :)

I went and started a new TS project. It has not shown the fault again, but I think this problem may have to do with the fact that after one works with settings inputs changing them and saving on Rusefi. Sometimes changing and saving inputs could cause fatal error even though inputs may not be overlapping. I believe that is what happened this time.

For now it seem to work fine. By the way the input I changed was PC2. I swapped it with PA0 I think, PC2 is the one that was causing all these unexpected values in Rusefi in the "settings" screen as you know.

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Sun Apr 07, 2019 6:45 pm

I have applied CurrentTune from MyCar34.zip and it kind of works

https://github.com/rusefi/rusefi/issues/736 created by that's a minor defect and I assume it's not what is affecting you
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Sun Apr 07, 2019 6:54 pm

russian wrote:
Sun Apr 07, 2019 6:45 pm
I have applied CurrentTune from MyCar34.zip and it kind of works

https://github.com/rusefi/rusefi/issues/736 created by that's a minor defect and I assume it's not what is affecting you
What happens to the MAp gauge when cranking? Does it fall to zero?

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Sun Apr 07, 2019 6:57 pm

I am not sure how to test that and I am not sure what's the point. I guess I recommend rebooting ECU after any change which touches pinout - usually people do not change pinout that often.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

mck1117
running engine in first post
running engine in first post
Posts: 241
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish
Soldering skill: yes
Coding skill?: yes

Re: Nissan on Frankenso #47

Post by mck1117 » Sun Apr 07, 2019 10:40 pm

This sounds to me like a wiring issue external to the rusEfi board. What kind of map sensor are you using? Where do each of the wires from the sensor go (be specific)?

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Sun Apr 07, 2019 11:53 pm

mck1117 wrote:
Sun Apr 07, 2019 10:40 pm
This sounds to me like a wiring issue external to the rusEfi board. What kind of map sensor are you using? Where do each of the wires from the sensor go (be specific)?
Mck1117 I asked if you could send me your TS project. If u can not do that can you advise how your cranking looks like?

It would be helpful to know your settings on: " Cranking Settings screen, Cranking fuel multiplier and cranking fuel duration?

Can you provide this info? I still have problems with cranking. The engine will not start. The injectors that I am using are 4.3mg/ms fuel or 317cc/min
Volvo standard Bosch injectors, the time for prime is 3.58ms fuel or 15mg per cycle, the MAP is about 0.4 bars and the displacement volume of the cylinder is 0.464cm3.

My settings right now are as follows see picture.
Attachments
IMG_6877.JPG
IMG_6877.JPG (2.71 MiB) Viewed 540 times

Abricos
contributor
contributor
Posts: 718
Joined: Mon Aug 18, 2014 12:32 am

Re: Nissan on Frankenso #47

Post by Abricos » Mon Apr 08, 2019 12:25 am

filip5 wrote:
Sun Apr 07, 2019 11:53 pm
mck1117 wrote:
Sun Apr 07, 2019 10:40 pm
This sounds to me like a wiring issue external to the rusEfi board. What kind of map sensor are you using? Where do each of the wires from the sensor go (be specific)?
Mck1117 I asked if you could send me your TS project. If u can not do that can you advise how your cranking looks like?

It would be helpful to know your settings on: " Cranking Settings screen, Cranking fuel multiplier and cranking fuel duration?

Can you provide this info? I still have problems with cranking. The engine will not start. The injectors that I am using are 4.3mg/ms fuel or 317cc/min
Volvo standard Bosch injectors, the time for prime is 3.58ms fuel or 15mg per cycle, the MAP is about 0.4 bars and the displacement volume of the cylinder is 0.464cm3.

My settings right now are as follows see picture.
I think you need check your local tuner shop !!!

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 3:18 am

russian wrote:
Sun Apr 07, 2019 6:57 pm
I am not sure how to test that and I am not sure what's the point. I guess I recommend rebooting ECU after any change which touches pinout - usually people do not change pinout that often.
Can you post a picture of Rusefi sniffer during your engine cranking? Something like the\is one attached.
Attachments
Cranking.JPG
Cranking.JPG (2.46 MiB) Viewed 525 times

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Mon Apr 08, 2019 4:01 pm

kb1gtt wrote:
Thu Apr 04, 2019 2:01 am
Your offer for us to come to your shop does not help. We have trouble getting to our own garages.
I am afraid this is a big part of the lack of detailed responses :(

I would like to reiterate that you have an option to see my configuration using https://raw.githubusercontent.com/rusef ... button.png button
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 5:33 pm

russian wrote:
Mon Apr 08, 2019 4:01 pm
kb1gtt wrote:
Thu Apr 04, 2019 2:01 am
Your offer for us to come to your shop does not help. We have trouble getting to our own garages.
I am afraid this is a big part of the lack of detailed responses :(

I would like to reiterate that you have an option to see my configuration using https://raw.githubusercontent.com/rusef ... button.png button
Sorry man, your settings do not help. There is not much there . There is nothing I can see. I suppose u have this engine running on empty

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 5:59 pm

Rusefi

It looks to me like your fuel injection calculator is maybe wrong.

If I have a 0.5 liter cylinder that we know at 20 degrees Celsius weighs 1.2 grams per liter or the weight of air in 0.5 liter cyl is 0.6 grams. If I consider that my MAP is let say85kpa that would make the air in cylinder 0.8 Bar pressure or simplified the cylinder is filled 0.6x0.85=0.51 gram air. Now to have the AFR at 14.60 as per your calculator the amount of gasoline should be 0.51:14.60=0.035 grams or 35 mg. At 315 cc/min it will inject 5.25 cc/sec or 5.25*0.74 g/cm3 for gasoline=3.89gr/sec or 3.89mg/ms. So based on this the inject time should be 35 mg/ 3.89mg/ms=9ms but Rusefi shows only 4.29ms. See attached pict. For the tests that I did a 315cc injector objects 4.3 mg/ ms at 14 volts and not 3.89mg/ms but that is not the issue.

Am I wrong here?

Also during cranking rusefi seem to take inject values direct form VE table even though cranking boundaries are outside of the boundaries for that table and should follow cranking settings I believe that is why my engine does not start . I wonder how do yours?
The inject times are not from the cranking settings from the tests that I did. Is this correct or am I wrong? Cranking table and multipliers seem to do nothing.

Ps One more thing . Is your PWM working during cranking because I don’t think so?
Attachments
image.jpg
image.jpg (2.61 MiB) Viewed 490 times

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Mon Apr 08, 2019 6:13 pm

Just made a code change to reduce confusion with formulas - see new warning in red. Cranking fuel logic is not shown on the formulas, so no issue here - just ignore the formulas while cranking. Thank you for your feedback - it was definitely confusing and I hope it's a bit less confusing now.

https://getsharex.com is a great utility to make screenshots and screen recording. Can you please record how do you use the preset buttons so that these do not work for you? Last time I've checked (pretty recently) these buttons were applying settings.

About formulas being wrong. Please make a complete screenshot of wrong values and please explicitly state which part of the formula is wrong in your opinion, or do you see a problem with arithmetic, or what is wrong _EXACTLY_. Please do the comparison and point at the difference between what you see with rusEfi and what you believe is right.
Attachments
java_D3FnXKgsG8.png
java_D3FnXKgsG8.png (125.37 KiB) Viewed 480 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 6:30 pm

russian wrote:
Mon Apr 08, 2019 6:13 pm
Just made a code change to reduce confusion with formulas - see new warning in red. Cranking fuel logic is not shown on the formulas, so no issue here - just ignore the formulas while cranking. Thank you for your feedback - it was definitely confusing and I hope it's a bit less confusing now.

https://getsharex.com is a great utility to make screenshots and screen recording. Can you please record how do you use the preset buttons so that these do not work for you? Last time I've checked (pretty recently) these buttons were applying settings.

About formulas being wrong. Please make a complete screenshot of wrong values and please explicitly state which part of the formula is wrong in your opinion, or do you see a problem with arithmetic, or what is wrong _EXACTLY_. Please do the comparison and point at the difference between what you see with rusEfi and what you believe is right.
I did not say that the post I wrote about formulas was about cranking? The engine is running and I am showing your formulas to be wrong.

On the other hand you did not answer the fact that about cranking issue.

I repeat, your cranking settings are not working. The inject values during cranking are taken out of VE table and since the RPM is below the min values of the table rusefi picks up the lowest value of the table that is 600 rpm or whatever that is and the corresponding map

Why are the settings of the cranking not working?

Why is rusefi PWM not working?

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Mon Apr 08, 2019 6:41 pm

I have no idea what we are talking about. Please decide which ONE issue you would like to discuss and let's try again from zero. Please decide if we discuss cranking or running, not both at the same time.

For whatever issue you would like to report, please help me understand you. At the moment I have no idea what seems to be the problem, what are your arguments and how do you get to the conclusion that there some problem. Please be more detailed and please point at the exact problem.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 6:43 pm

russian wrote:
Mon Apr 08, 2019 6:41 pm
I have no idea what we are talking about. Please decide which ONE issue you would like to discuss and let's try again from zero. Please decide if we discuss cranking or running, not both at the same time.

For whatever issue you would like to report, please help me understand you. At the moment I have no idea what seems to be the problem, what are your arguments and how do you get to the conclusion that there some problem. Please be more detailed and please point at the exact problem.
Ok. This is the issue. Is rusefi cranking section working?

Second is the PWM working in that section during cranking?

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Mon Apr 08, 2019 6:54 pm

filip5 wrote:
Mon Apr 08, 2019 6:43 pm
Ok. This is the issue. Is rusefi cranking section working?
This is a vague question. This question could mean a million different things. I am sure that rusEfi can start a cold or warm 4 or 8 cylinder engine.
filip5 wrote:
Mon Apr 08, 2019 6:43 pm
Second is the PWM working in that section during cranking?
PWM of WHAT? pulse wave modulation of what? Pulse wave modulation of headlights? No such thing. Pulse wave modulation of idle air solenoid? Yes it should work. Pulse wave modulation of VVT solenoid? Yes I think so. Pulse wave modulation or brake lights? No.

Please use you favorite image editor to highlight the exact context of TS menus in RED because at the moment I am not sure what you are talking about.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Mon Apr 08, 2019 7:06 pm

https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

theflyingdutchp
Posts: 91
Joined: Wed May 18, 2016 11:03 pm

Re: Nissan on Frankenso #47

Post by theflyingdutchp » Mon Apr 08, 2019 7:21 pm

filip5 wrote:
Mon Apr 08, 2019 5:59 pm
It looks to me like your fuel injection calculator is maybe wrong.

....

Am I wrong here?
Yes, you never applied the VE %.

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 7:26 pm

russian wrote:
Mon Apr 08, 2019 6:54 pm
filip5 wrote:
Mon Apr 08, 2019 6:43 pm
Ok. This is the issue. Is rusefi cranking section working?
This is a vague question. This question could mean a million different things. I am sure that rusEfi can start a cold or warm 4 or 8 cylinder engine.
filip5 wrote:
Mon Apr 08, 2019 6:43 pm
Second is the PWM working in that section during cranking?
PWM of WHAT? pulse wave modulation of what? Pulse wave modulation of headlights? No such thing. Pulse wave modulation of idle air solenoid? Yes it should work. Pulse wave modulation of VVT solenoid? Yes I think so. Pulse wave modulation or brake lights? No.

Please use you favorite image editor to highlight the exact context of TS menus in RED because at the moment I am not sure what you are talking about.
Okay, this is the question:
1-How do you control injection time during cranking? Which value in the "cranking section" controls it so If I change it the value for the fuel injection will Nanchang?
2- Is the cranking coolant fuel temperature multiplier working? I change it and does not seem to have any effect on the fuel injection time during cranking?

3- The fuel seem to be not evaporating during cranking. It ends up as a liquid inside the cylinder and makes spark plugs wet. How can this be fixed to help fuel evaporate and not stay liquid.

Being that I can not control these values from Cranking settings the only option is the VE table from which Rusefi seem to take the values for injection during cranking.

Am I clear enough?

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 7:27 pm

theflyingdutchp wrote:
Mon Apr 08, 2019 7:21 pm
filip5 wrote:
Mon Apr 08, 2019 5:59 pm
It looks to me like your fuel injection calculator is maybe wrong.

....

Am I wrong here?
Yes, you never applied the VE %.
I believe the formula is there to tell me what the value of the fuel injection should be for a certain settings of the VE table so If I am wrong I can correct it.

Why do I have to apply the VE % ? What is the purpose of the formula then?

ZHoob2004
contributor
contributor
Posts: 145
Joined: Sun Apr 03, 2016 7:11 pm

Re: Nissan on Frankenso #47

Post by ZHoob2004 » Mon Apr 08, 2019 7:38 pm

filip5 wrote:
Mon Apr 08, 2019 7:27 pm
theflyingdutchp wrote:
Mon Apr 08, 2019 7:21 pm
filip5 wrote:
Mon Apr 08, 2019 5:59 pm
It looks to me like your fuel injection calculator is maybe wrong.

....

Am I wrong here?
Yes, you never applied the VE %.
I believe the formula is there to tell me what the value of the fuel injection should be for a certain settings of the VE table so If I am wrong I can correct it.

Why do I have to apply the VE % ? What is the purpose of the formula then?
The formula calculates the fuel for the displacement of the engine at manifold pressure. VE is the percentage of that air that actually makes it into the cylinder before the valves close. VE is really only an approximation, and should be adjusted based on the AFR you measure from the engine.

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 7:47 pm

ZHoob2004 wrote:
Mon Apr 08, 2019 7:38 pm
filip5 wrote:
Mon Apr 08, 2019 7:27 pm
theflyingdutchp wrote:
Mon Apr 08, 2019 7:21 pm
filip5 wrote:
Mon Apr 08, 2019 5:59 pm
It looks to me like your fuel injection calculator is maybe wrong.

....

Am I wrong here?
Yes, you never applied the VE %.
I believe the formula is there to tell me what the value of the fuel injection should be for a certain settings of the VE table so If I am wrong I can correct it.

Why do I have to apply the VE % ? What is the purpose of the formula then?
The formula calculates the fuel for the displacement of the engine at manifold pressure. VE is the percentage of that air that actually makes it into the cylinder before the valves close. VE is really only an approximation, and should be adjusted based on the AFR you measure from the engine.
Ok. So this formula is useless to me. I don't need to see it. Now I know. It confused the hell out of me.Thank you.

You seem to be very well informed. Can you answer these questions:

1-How do you control injection time during cranking? Which value in the "cranking section" controls it so If I change it the value for the fuel injection will change?

2- Is the cranking coolant fuel temperature multiplier working? I change it and does not seem to have any effect on the fuel injection time during cranking? Why is that?

3- The fuel seem to be not evaporating during cranking. It ends up as a liquid inside the cylinder and makes spark plugs wet. How can this be fixed to help fuel evaporate and not stay liquid?

Being that I can not control these values, meaning "fuel injection time", from Cranking settings and the only option is the VE table from which Rusefi seem to take the values for injection during cranking.
Attachments
Cranking Settings.JPG
Cranking Settings.JPG (2.71 MiB) Viewed 458 times

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Mon Apr 08, 2019 7:54 pm

I should be able to respond in two hours.

Please post a log of your cranking. File type MSL i believe
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 7:57 pm

russian wrote:
Mon Apr 08, 2019 6:54 pm
filip5 wrote:
Mon Apr 08, 2019 6:43 pm
Ok. This is the issue. Is rusefi cranking section working?
This is a vague question. This question could mean a million different things. I am sure that rusEfi can start a cold or warm 4 or 8 cylinder engine.
filip5 wrote:
Mon Apr 08, 2019 6:43 pm
Second is the PWM working in that section during cranking?
PWM of WHAT? pulse wave modulation of what? Pulse wave modulation of headlights? No such thing. Pulse wave modulation of idle air solenoid? Yes it should work. Pulse wave modulation of VVT solenoid? Yes I think so. Pulse wave modulation or brake lights? No.

Please use you favorite image editor to highlight the exact context of TS menus in RED because at the moment I am not sure what you are talking about.
I think Rusefi can start a warm engine just fine and I tested it myself. The problem is that Rusefi can not start a cold engine and that is my problem and probably yours too.

User avatar
russian
Site Admin
Posts: 9683
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Nissan on Frankenso #47

Post by russian » Mon Apr 08, 2019 8:00 pm

Sometimes I ask myself if I a got enough of your attitude and if I should simply block you. I do not appreciate your misplaced assumptions on what are my problems or what my priorities should be.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

filip5
donator
donator
Posts: 144
Joined: Sat Apr 15, 2017 6:14 pm

Re: Nissan on Frankenso #47

Post by filip5 » Mon Apr 08, 2019 8:14 pm

russian wrote:
Mon Apr 08, 2019 8:00 pm
Sometimes I ask myself if I a got enough of your attitude and if I should simply block you. I do not appreciate your misplaced assumptions on what are my problems or what my priorities should be.
Listen man,

You referred me to submit questions to your forums. I am asking questions and I am not getting straight answers. Only turn arounds.

I invested myself on Rusefi hoping that I would be able to run an engine. I am not holding you to anything but I am just saying.

If you do not wish me to post or do not want to offer any help that is fine, you don't have to.

ZHoob2004
contributor
contributor
Posts: 145
Joined: Sun Apr 03, 2016 7:11 pm

Re: Nissan on Frankenso #47

Post by ZHoob2004 » Mon Apr 08, 2019 8:18 pm

filip5 wrote:
Mon Apr 08, 2019 7:47 pm
1-How do you control injection time during cranking? Which value in the "cranking section" controls it so If I change it the value for the fuel injection will change?

2- Is the cranking coolant fuel temperature multiplier working? I change it and does not seem to have any effect on the fuel injection time during cranking? Why is that?

3- The fuel seem to be not evaporating during cranking. It ends up as a liquid inside the cylinder and makes spark plugs wet. How can this be fixed to help fuel evaporate and not stay liquid?

Being that I can not control these values, meaning "fuel injection time", from Cranking settings and the only option is the VE table from which Rusefi seem to take the values for injection during cranking.
1 - I've only ever adjusted "Base Fuel Pulse Width", seen about 3/4 of the way down your screenshot. I believe I have it set to 3.5-4.0ms. That's on a 1.6L 4cyl with 240cc injectors.

2 - As far as I know, yes, the coolant multiplier does work. I think the right way to tune this is to figure out what settings feel good for warm starts, then turn up the multipliers as you attempt cold starts and see what works. This is going to be more of a "feel" thing than anything else.

3 - This sounds like too much fuel, but I'm not super knowledgeable on the exact theory of this. When you're cranking, does the exhaust smell rich? How about AFR while cranking?

Here, I took a screenshot of all my cranking settings together. I had to reset IAC to 0 because some configuration change made that value go crazy (was some weird negative number)

EDIT: I'm pretty sure these are just the default 1.6 Miata values, except I reduced the fuel pulse width from 5.0 to 4.0, which felt better to me.
ignition settings.jpg
ignition settings.jpg (288.94 KiB) Viewed 448 times
Last edited by ZHoob2004 on Mon Apr 08, 2019 8:27 pm, edited 1 time in total.

ZHoob2004
contributor
contributor
Posts: 145
Joined: Sun Apr 03, 2016 7:11 pm

Re: Nissan on Frankenso #47

Post by ZHoob2004 » Mon Apr 08, 2019 8:21 pm

filip5 wrote:
Mon Apr 08, 2019 7:57 pm
I think Rusefi can start a warm engine just fine and I tested it myself. The problem is that Rusefi can not start a cold engine and that is my problem and probably yours too.
This is the sort of comment that is turning people off from helping you. RusEFI has no problems starting an engine, warm or cold. You are the one that is having a problem, and we're trying to help you, but a lot of your replies are coming off a bit abrasive, and it's wearing down people's patience.

Post Reply