1989 E30 Touring #48

What engine are you torturing? Is it inside some car?
Post Reply
OrchardPerformance
contributor
contributor
Posts: 140
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

1989 E30 Touring #48

Post by OrchardPerformance » Sun Apr 28, 2019 9:02 pm

I thought I should get a my car thread up now that it's running.

Ill fill out some info in this first post later on when I have a bit of time free but the short version is:- the car began life as a 320, gained a 2.5 lump a while back and has since been running on the later 24v ECU from an E36. What this means is my wiring is the same as a M50TU engine E36, but the car is still running a M20B25.

My original intent was to use the later ECU and an EPROM emulator to get the car running on a more tunable/advanced ECU but with all the stock hardware still working as it should (OBC, SI unit, Tach, Econometer etc).
That has kind of fallen apart over the last year as there is just not enough info on the OEM to get it really running properly on the 12v engine.

This is where the rusEFI comes in, my plan is to first get the car running well with the existing functions and then look at being able to replicate the OEM ecu outputs that run the additional bits on the E30 for a seamless install.

Now that my Frankenso is built and the car is running to some extent I need to start documenting the wiring and looking at getting some of these features working.

OrchardPerformance
contributor
contributor
Posts: 140
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

Re: 1989 E30 Touring #48

Post by OrchardPerformance » Sun Apr 28, 2019 9:04 pm

This post reserved for wiring. :!:

Attached is my current wiring guide, this works for my E30 due to the 88pin ECU swap, this should also work for single Vanos M50 E36 cars as well.
I am sure there are mistakes here and I will address these as I find them, but for now this is the wiring.

To get the Frankenso wired up to the car I put together an adapter loom from an old 88pin ECU and some plugs from a toyota truck (all prestige kit here :lol: )

Image
Image

I needed to get something cobbled together to run the stock BMW coils as the IGBTs for them are normally in the ECU. I found some VW 4 cylinder IGBT packs from a VW Passat B5 1.8t, pretty sure they are used on others as well but they are pretty cheap.
They needed heat sinking so I built a little setup that mounts a pack on either side of a 40mm piece of speed frame.
This has since needed a 40mm fan added to the end to improve the cooling a bit, these get pretty warm.
Image

To get the 3 wire ICV working I have the closing winding earthed via a 47ohm 25w resistor. This means you can just set the ICV duty as though it was a spring loaded ICV and it seems to be working like that just fine. Future upgrade for sure would be to get that working as it should be with a proper open and close control.
Image

Once in the car I had a slightly odd issue with the USB connection keeping the car switched on by preventing the main relay from closing, to get around this I have hooked up a little transistor board so that the Frankenso is not triggering the relay directly. Not 100% what the issue was/is here but the transistor solved it.
Is similar issue seemed to be present with the SI board so I added a transistor for this and for the Tach to keep the dash isolated from the Frankenso.
The only thing I can think of is that the dash is always live and seems to be able to earth a little through something on the Frankenso.
Having checked a bit my Frankenso reads ~1700 Kohms from W35 and W36 to ground, (only on these two pins) perhaps there's some leakage to earth here?
Image

My Frankenso is pinned up as follows:-
Using page 1 of the schematic to ID pins: FORMAT: Number - Jumper - STMpin - plug pin

Crank
Crank+ - - - 2A
Crank- - - - 2B
Cam+ - - - 2C
Cam- - - - 2D REPIN

12v:
12v - W2 - - 1B

5V OUT:
5v - W49 - - 3K

Injectors:
1 - W61 - PB9 - 3W
2 - W60 - PE2 - 3V
3 - W63 - PB8 - 3Y
4 - W64 - PB7 - 3Z
5 - W62 - PD5 - 3X
6 - W59 - PD3 - 3U

Coils:
1 - W7 - PC9 - 1F
2 - W6 - PC7 - 1H REPIN
3 - W8 - PE14 - 1G REPIN
4 - W13 - PE12 - 1M
5 - W12 - PE10 - 1I
6 - W9 - PE8 - 1L
To use the 4 clylinder VAG ICM, the 5 pin side is for the ECU and the 4 pin side to the coils.

Tach output:
1 - W38 - PE6 - 2P - Wired via PNP transistor

Fuel Rate Output:
1 - W37 - PE5 - 2O - not yet configured as pin out yet

Fuel Pump:
1 - W58 - PE4 - 3S

Knock Sensors:
1 - W30 - PB15 Knock 0 - 2G
2 - W29 - PB14 Knock 1 - 2H

Analog Sensors:
TPS - W51 - PA2 - 3M
CLT - W55 - PC2 - 3Q
IAT - W54 - PC1 - 3P
MAF - W50 - PA1 - 3L
MAP - W53 - PA0 - 3O
VSS - W48 - PA3 - 3J
VBATT - W43 - PC5 - 3E
WBO2 - W52 - PC3 - 3N - On AFR input
Main Relay:
MR - W36 - PD7 - 2N - This pin was causing the SI board lights to flash, checked and 12v was dropping to 5-8v, tried "open collector" and that had no effect so added PNP transistor board for this relay, the fuel rate and the tach.

Idle:
IAC Open - W39 - PC13 - 2M - if set so idle is pulled closed and swings open, better to idle high than stall, will the PID fail to work?
IAC Close - - - - Currently pulled down with resistor.

Control Area Network:
CAN H - W33 - PB12 - 2K
CAN L - W34 - PB6 - 2L

Coolant Fan Relay:
CFR

Ground:
3A
3B REPIN
3C REPIN
3D REPIN

SPARE:
PA4
Attachments
M50 Pinout.jpg
M50 Pinout.jpg (736.5 KiB) Viewed 135 times
Last edited by OrchardPerformance on Sun Apr 28, 2019 10:54 pm, edited 3 times in total.

OrchardPerformance
contributor
contributor
Posts: 140
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

Re: 1989 E30 Touring #48

Post by OrchardPerformance » Sun Apr 28, 2019 9:31 pm

First couple of issue to solve right now are the Tachometer (rev counter) and the VBatt.

VBatt :-
To keep the install neat I jumpered W44 to the via next to the main 5A fuse to pick up the incoming 12v supply. For some reason this currently is not working properly, I have a feeling I did something dumb here as I get a fixed VBatt value in tunerstudio regardless of the battery voltage.
I need to check out the schematic and have another think about this one.

Tachometer output :- I have the tach output on the Frankenso set up and working ok (but it appears to give a different RPM to the correct value, an issue for later when I work it out).
The issue here is that I cannot get the dash to trigger.
The Tach on the dash appears to use a 12v supply from the clocks that is earthed by the ECU at a frequency that reflects the current engine RPM.
I put together a transistor board to trigger this from a NPN transistor which appears to be working but the dash is not triggering.

I have attached the wiring diagrams for both the E30 and E36 Tach which I believe are the same, they certainly both worked fine with the cross over of OEM ecus.
Attachments
E36 Tach.JPG
E36 Tach.JPG (23.02 KiB) Viewed 138 times
E30 Tach.JPG
E30 Tach.JPG (264.33 KiB) Viewed 138 times

Post Reply