[rusEfi] Miata NA 1990, 1.6L stock #21

What engine are you torturing? Is it inside some car?
User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Thu Feb 09, 2017 4:10 am

Nokia 2GB card also works always

SanDisk 1GB card worked once and does not work anymore, WAT?

unmarked 2GB card does not work - formatted FAT

SAMSUNG 1GB works

same SAMSUNG 1GB works just formatted it FAT32 and it still works! Good news FAT32 is supported I did not know that.

Kingston 8GB FAT32 card works

another SanDisk 1GB worked couple of times already

another SanDisk 2GB worked once and now it does not work any more.


I've just wasted 2 hours of my life on unreliable SD cards :(

Technically my collection is too small for a good analysis but all cards which worked on a PC but not reliable on rusEfi are either unmarked or SanDisk.

update: unmarked 32GB FAT32 works on my Rev D card Frankenstein board

sony 8gb does not work
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Thu Feb 09, 2017 4:17 am

russian wrote: Are you using same board same SD card in both cases?
I'm using a Kingston 16GB card formatted FAT32 on the Frankenso powered from the car 12v. I'll try a small card to see if it makes a difference.
Last edited by tomiata on Thu Feb 09, 2017 4:52 am, edited 2 times in total.

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Thu Feb 09, 2017 4:37 am

Interesting, even relatively large lot of used small 2GB cards - http://www.ebay.com/itm/222401344036 - still above $2 per card.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Thu Feb 09, 2017 4:51 am

tomiata wrote:
russian wrote: Are you using same board same SD card in both cases?
I'm using a Kingston 16GB card formatted FAT32 on the Frankenso powered from the car 12v. I'll try a small card to see if it makes a difference.
RevC Discovery on Frankenso in car, 1G Kingston FAT format

2017-02-08 22_27: EngineState: confirmation_ls /:4
2017-02-08 22_27: EngineState: ls_result
2017-02-08 22_27: EngineState: logfile36948:rus1.msl
2017-02-08 22_27: EngineState: confirmation_sdinfo:6
2017-02-08 22_27: EngineState: MMC CS PD4
2017-02-08 22_27: EngineState: SD enabled: Yes [rus1.msl]
2017-02-08 22_27: EngineState: fs_ready=Yes totalLoggedBytes=40476

RevD Discovery on Frankenso in car, 1G Kingston FAT format

2017-02-08 22_33: EngineState: confirmation_ls /:4
2017-02-08 22_33: EngineState: Error: No File system is mounted
2017-02-08 22_33: EngineState: confirmation_sdinfo:6
2017-02-08 22_33: EngineState: MMC CS PD4
2017-02-08 22_33: EngineState: SD enabled: Yes []
2017-02-08 22_33: EngineState: fs_ready=No totalLoggedBytes=0

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Thu Feb 09, 2017 4:54 am

Did you mention you have more than one Rev D board? Do you have more than two boards total?

With my testing today I am convinced Rev D SD works at least sometimes.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Thu Feb 09, 2017 5:38 am

Yes, I have 2 RevD boards and 1 RevC, not counting a RevC board that I killed with 12v applied to the 5v input.

User avatar
kb1gtt
contributor
contributor
Posts: 3489
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by kb1gtt » Thu Feb 09, 2017 11:02 am

Some items to keep an eye out for include SD card vs MMC, as well there are special SD cards which are commonly used on PLC's which have special extra security features. Do you expect the SD cards are all generic camera SD cards? Do they all have the same pin out as noted below.
sdmm_contact.jpeg
sdmm_contact.jpeg (57.88 KiB) Viewed 2531 times
Also lets not forget the read / write switch position.
W20110106-Langa-SDLock.jpg
W20110106-Langa-SDLock.jpg (32.83 KiB) Viewed 2531 times
Welcome to the friendlier side of internet crazy :)

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Thu Feb 09, 2017 12:52 pm

Pictured are sd cards, our boards take microSD - too small for a key
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

puff
contributor
contributor
Posts: 2739
Joined: Mon Nov 11, 2013 11:28 am
Location: Moskau

Re: Miata NA 1990, 1.6L stock #21

Post by puff » Thu Feb 09, 2017 12:58 pm

RevC & RevD refers to stm board, right? Frankenso (or whatever it is) is the same? So, probably, something inside discovery is broken? Have you checked errata?

puff
contributor
contributor
Posts: 2739
Joined: Mon Nov 11, 2013 11:28 am
Location: Moskau

Re: Miata NA 1990, 1.6L stock #21

Post by puff » Thu Feb 09, 2017 1:02 pm

one more note on cheap cards with large capacity sold on ebay. often they are not as large as they may seem. e.g. the descriptor might show that it is 2GB card, while the actual available capacity is 256MB or less. And nobody knows what happens when you try to write down data in the addresses higher than those 256MB. There are utilities on the net that help identify the actuall capacity of the card.

User avatar
kb1gtt
contributor
contributor
Posts: 3489
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by kb1gtt » Thu Feb 09, 2017 5:03 pm

Is the software expecting SD or MMC? We have SD, but could there be a software compatibility issue with MMC? Sorry just a wild ass guess.
Welcome to the friendlier side of internet crazy :)

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Thu Feb 09, 2017 5:05 pm

Each SD is an MMC I believe? See http://www.diffen.com/difference/MMC_vs_SD_Card
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Thu Feb 09, 2017 9:59 pm

tomiata wrote:Attached is current tune
Why analogInputDividerCoefficient = 2.5? That's a big question since this affects pretty much all calibrations and everything.

injector_flow = 215 why not 230 as on http://miataturbo.wikidot.com/fuel-injectors and http://www.miataturbo.net/useful-saved- ... post513134 ? that's a much smaller question.

globalTriggerAngleOffset = 16 tell me when it would be a good day for me to change firmware so those 16 are part of trigger and you do not need to have any extra offset.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Fri Feb 10, 2017 2:37 am

Tom so you have only tried one SD card? Do you want to order http://www.ebay.com/itm/401270523426 since these are two different cards?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Fri Feb 10, 2017 3:36 am

russian wrote:Tom so you have only tried one SD card? Do you want to order http://www.ebay.com/itm/401270523426 since these are two different cards?
See above, the last thing I tried last night was a 1GB Kingston FAT format card. I had been using a 16GB FAT32 formated Kingston card for a month or so. Both show the same results. I have some 32GB Samsung for the gopro that I can try. I may have some others laying around.

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Sat Feb 11, 2017 2:06 am

Some good news...
I bought a new Sandisk 8GB card at walmart, FAT32 format, and it worked with the RevD board with 2/4 firmware on Frankenso in the car.

But, some new problems with this config with engine running rough and very rich and feels like running on 2 cylinders.
Also, new warnings on TPS:
low: -1.20,msg,WARNING: TPS too low: -1.28,msg,WARNING: TPS too low: -1.28,msg,WARNING: TPS too low: -1.28,msg,WARNING: TPS too low: -1.20,msg,WARNING: TPS too low: -1.20,msg,WARNING: TPS too low: -1.04,msg,WARNING: TPS too low: -1.04,msg,WARNING: TPS too

And recalibrating TPS did not fix it...

I'll gather up more logs and post.

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Sat Feb 11, 2017 2:55 am

So why multiplier 2.5 and flow 215?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Sat Feb 11, 2017 3:42 am

russian wrote:So why multiplier 2.5 and flow 215?
Sorry, didn't get around to answering this earlier.

The 2.5 Analog divider (coef) came from the tune I started with from @thommm's smurf tune. I didn't notice that it was different from standard.
The injector flow came from a reference I found when I searched around forums to check the value for the injectors I have. I don't remember where I got that.

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Sat Feb 11, 2017 3:46 am

tomiata wrote:The 2.5 Analog divider (coef) came from the tune I started with from @thommm's smurf tune.
Problem is actual hardware is a 2.0 analog divider. And changing this value would throw everything off.

But using the real divider is probably the right thing to do? But it would throw all you sensor calibrations and maps off.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Sat Feb 11, 2017 4:27 am

russian wrote:
tomiata wrote:The 2.5 Analog divider (coef) came from the tune I started with from @thommm's smurf tune.
Problem is actual hardware is a 2.0 analog divider. And changing this value would throw everything off.

But using the real divider is probably the right thing to do? But it would throw all you sensor calibrations and maps off.
I got this going through much trial and error, and not knowing what I was doing. I want to make it all as it should be to follow "standard" settings. I don't mind changing it.

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Sat Feb 11, 2017 4:34 am

Here is the chart where I found the 215 value for injector flow volume.
http://www.robietherobot.com/storm/fuel ... rguide.htm

Btw, the smurf tune had a value of 200.

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Sat Feb 11, 2017 12:50 pm

Let's start by changing multiplier to 2.0

I've actually realized maybe only sensors would need to be re-calibrated but maps would stay the same.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
kb1gtt
contributor
contributor
Posts: 3489
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by kb1gtt » Sat Feb 11, 2017 1:15 pm

Is there a jumper wire configuration for this setup? Or was this just 0R's I know we tried to make it work with some specific setups, but other models have different pin outs. Keep in mind we can make a small PCB which can be put over the jumper area, then you can solder the via's on this PCB and it can function as the jumper wires, instead of installing a bunch of wires.
Welcome to the friendlier side of internet crazy :)

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Sat Feb 11, 2017 1:16 pm

kb1gtt wrote:Is there a jumper wire configuration for this setup?
http://rusefi.com/forum/viewtopic.php?f=4&t=1174
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Sat Feb 11, 2017 10:02 pm

russian wrote:Let's start by changing multiplier to 2.0

I've actually realized maybe only sensors would need to be re-calibrated but maps would stay the same.
Ok. I changed the multiplier to 2.0 and I'm reworking the settings using the RevD Discovery board. Now I see why it was so hard to get my CLT and IAT to match reality. I had to fudge the bias resistor settings to make it work before. I thought there was a problem with my sensors or something.

Also, when I first installed the MPX4250 map sensor originally, the built-in setting didn't work right and set up custom config to make it work.
I still need to fix the WBO inputs. The rusefi readings are off from the AFR gauge. But the car starts ok.
I recalibrated TPS, but still get the TPS warnings about too high or too low.

When I tried it last night it was running very rough and seemed like was running on 2 or 3 cylinders. But today (before i started work on the sensor settings) it ran ok. I checked all the plug wires and saw flashes on a timing light. I don't know what was going on there. That's all the time I have for this now. I'll work on WBO later. It's good to know why I had so much trouble before.

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Thu Feb 16, 2017 4:03 am

I got WBO straightened out and recalibrated. Now running with Feb. 4 firmware on revD board with prototype top side sdcard (thanks @russian for sending that!)

Sensors are recalibrated and car is running with a rough tune. I turned off the closed loop fuel correction option. Should I try that yet?

Response is not quite as good as previous stable config, but needs more run time. Here is the current tune and logs from a drive.
Attachments
CurrentTune.msq
(134.19 KiB) Downloaded 144 times
rus-2017-02-15.msl
(928.35 KiB) Downloaded 198 times

stefanst
contributor
contributor
Posts: 579
Joined: Wed Feb 17, 2016 12:24 am

Re: Miata NA 1990, 1.6L stock #21

Post by stefanst » Thu Feb 16, 2017 6:51 pm

tomiata wrote:I got WBO straightened out and recalibrated. Now running with Feb. 4 firmware on revD board with prototype top side sdcard (thanks @russian for sending that!)

Sensors are recalibrated and car is running with a rough tune. I turned off the closed loop fuel correction option. Should I try that yet?

Response is not quite as good as previous stable config, but needs more run time. Here is the current tune and logs from a drive.
As soon as you have the VE table tuned reasonably well, you can engage CL for AFR. Wouldn't do it before that.

tomiata
contributor
contributor
Posts: 231
Joined: Sat Aug 02, 2014 2:30 am
Location: Texas

Re: Miata NA 1990, 1.6L stock #21

Post by tomiata » Sat Feb 18, 2017 12:57 am

Sensors are calibrated now, and tune is fairly stable running Feb. 15 firmware on revD Discovery.

But I still get lots of warnings, like about 460 per second. Looks like all are TPS too high or too low.
Any idea what's going on there?
Attachments
rus-2017-02-17-2.msl
(668.12 KiB) Downloaded 194 times

stefanst
contributor
contributor
Posts: 579
Joined: Wed Feb 17, 2016 12:24 am

Re: Miata NA 1990, 1.6L stock #21

Post by stefanst » Sat Feb 18, 2017 1:08 am

tomiata wrote:[...]
But I still get lots of warnings, like about 460 per second. Looks like all are TPS too high or too low.
Any idea what's going on there?
Don't know what's going on, but I'm getting the same messages, running your tune with a stimulator.

User avatar
russian
Site Admin
Posts: 9788
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Miata NA 1990, 1.6L stock #21

Post by russian » Sat Feb 18, 2017 1:12 am

I know what's going on :)

Just updated https://svn.code.sf.net/p/rusefi/code/t ... or_codes.h file mentioned on the minimalistic
http://rusefi.com/wiki/index.php?title= ... rror_codes page

I bet your configuration has grandfathered both TPS low and high value detection thresholds as zero. My bad these settings were not exposed in the TS project - just commited, these would appear below "tps adc channel" setting. You probably want the defaults which are -10% for too low error and 110% for too high error.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

Post Reply