ETB or 36/1 performance issue?

It's all about the code!
Post Reply
rene325
Posts: 4
Joined: Mon Apr 11, 2016 9:58 am

ETB or 36/1 performance issue?

Post by rene325 » Mon Sep 30, 2019 1:33 pm

Hi guys,
I'm also experimenting with ETB, in my setup I use a MC33866 H-Bridge and STM32F407VET6 Black.
I have a mechanical test setup with a 36-1 VR Trigger and a 1 Pulse CAM Trigger.

The ETB function works very well without triggers into the ECU (newest Rusefi firmware from Github), but when I simulate a running engine
i will go haywire when I pass around 3200-3700RPM. The ECU looses connection to Tunerstudio and Run and Comm indicators stops.

First I thought of noise from the ETB motor, but no, this even happends without the ETB motor connected. I traced it to : when I enable
"Throttle pedal Position Channel" in Tunerstudio the firmware goes haywire, even I did not configure any ETB outputs and no ETB connected.

I've made a short video of the issue, I hope one of you have an idea.
My coding skills is limited to Arduinos and old PIC's


NickZ
Posts: 14
Joined: Sun Sep 01, 2019 9:44 pm
Soldering skill: yes
Coding skill?: yes

Re: electronic throttle body control ETB

Post by NickZ » Mon Sep 30, 2019 1:57 pm

sharing a pin with something else?

User avatar
russian
Site Admin
Posts: 9673
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: electronic throttle body control ETB

Post by russian » Mon Sep 30, 2019 2:07 pm

do you have a 20x4 LCD to mount and read the message? what timezone are you in?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

rene325
Posts: 4
Joined: Mon Apr 11, 2016 9:58 am

Re: electronic throttle body control ETB

Post by rene325 » Mon Sep 30, 2019 2:35 pm

No shared pins.

I'm using PC1 as Throttle Pedal Position Channel, ETB Dir1 : PA15, ETB Dir2 : PC12, ETB Control : PD0

No errors in rusEFI console, which also stops communicating at the same RPM

No LCD connected, but I can connect one up, if that helps debugging.

I'm in CET timezone

User avatar
kb1gtt
contributor
contributor
Posts: 3469
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA
Contact:

Re: electronic throttle body control ETB

Post by kb1gtt » Mon Sep 30, 2019 4:16 pm

With out other stuff, can you open and close the ETB fully? I wonder if the higher amps at WOT are causing a ground to pull up and for the command bits to get lost as they might not generate enough voltage.
Welcome to the friendlier side of internet crazy :)

rene325
Posts: 4
Joined: Mon Apr 11, 2016 9:58 am

Re: electronic throttle body control ETB - performance issue?

Post by rene325 » Mon Sep 30, 2019 4:39 pm

It is probably not any gnd problems, because it does not matter if the ETB is connected.
Without ETB current draw is 175mA, with ETB going from closed to WOT around 1A, at steady state 50% throttle, current draw is around 700mA
Did anyone try to rev and hold their engine at 4000 rpms without issues ?

User avatar
russian
Site Admin
Posts: 9673
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: electronic throttle body control ETB - performance issue?

Post by russian » Thu Oct 03, 2019 12:41 pm

Funny thing is that connectivity returns once RPM go down - firmware is not hanging, it's just very unhappy.

This looks to be a software performance issue

Ticket created https://github.com/rusefi/rusefi/issues/965

Thank you Rene for reporting this and the troubleshooting session!
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

puff
contributor
contributor
Posts: 2733
Joined: Mon Nov 11, 2013 11:28 am
Location: Moskau

Re: electronic throttle body control ETB - performance issue?

Post by puff » Thu Oct 03, 2019 1:53 pm

is it at all related to etb?

User avatar
russian
Site Admin
Posts: 9673
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: electronic throttle body control ETB - performance issue?

Post by russian » Thu Oct 03, 2019 4:02 pm

probably not related at all. just highest PWM frequency. same could happen with idle solenoid or vvt solenoid
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

puff
contributor
contributor
Posts: 2733
Joined: Mon Nov 11, 2013 11:28 am
Location: Moskau

Re: electronic throttle body control ETB - performance issue?

Post by puff » Thu Oct 03, 2019 8:52 pm

not my case?
(I seem to have similar disconnects, but caused by noisy cps signal?)
how did rusefi_no_asserts help rene325?

Abricos
contributor
contributor
Posts: 717
Joined: Mon Aug 18, 2014 12:32 am

Re: electronic throttle body control ETB - performance issue?

Post by Abricos » Fri Oct 04, 2019 1:19 am

I have MRE ... And no problems ...

NickZ
Posts: 14
Joined: Sun Sep 01, 2019 9:44 pm
Soldering skill: yes
Coding skill?: yes

Re: ETB or 36/1 performance issue?

Post by NickZ » Sat Oct 12, 2019 8:48 am

Ive just been testing my new board and using 36-1 and electronic throttle body upto 6000 rpm with no problems, works great. the only thing i find is trying to get the ETB to follow the pedal, I can only use about 50% of the pedal and it will shoot upto 100% throttle body.

Old Grey
contributor
contributor
Posts: 67
Joined: Thu Apr 07, 2016 10:20 pm

Re: ETB or 36/1 performance issue?

Post by Old Grey » Sat Oct 12, 2019 11:32 am

Not that I know anything about it, but does it have a variable ratio activation table, ie, 0-50% on the pedal is 1:1, but 50-100 is 4:1. I know it was common in Supercars, but they did it mechanically with changing rate pulleys.
I don't even know about the sensors or actuators, but is there a mech ratio in the travel of either. ie, is the digital valve reported in the ECU linear with travel.

Post Reply