[info] Mary Shelley's Frankenso

Hardware inside and outside of the ECU
OrchardPerformance
contributor
contributor
Posts: 144
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

Re: Mary Shelley's Frankenso #48

Post by OrchardPerformance » Tue Apr 02, 2019 8:29 pm

Some kind of success - I followed your advice and grounded the circuit to trigger it, working from the Discovery back to the MAX9926.

3.3v from the resistors back to the Discovery and grounding it lit the LEDs next to the MAX9926 and registered a trigger event.
Other side of the MAX9926 resulted in nothing... :?

I had a speeduino VR board from another project to stole the MAX9926 from that board and swapped it with the one on the Frankenso, now triggering the crank inputs lights the LEDs and registers as an event.
Jumping the stimulator outputs to the input side of the MAX9926 now makes everything run so I might try firing the car up again tomorrow.

No idea what was wrong with the old chip but I will do some checking, it was one of the first things I did on the board so I may have damaged it with too much heat.

User avatar
kb1gtt
contributor
contributor
Posts: 3489
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA
Contact:

Re: Mary Shelley's Frankenso

Post by kb1gtt » Wed Apr 03, 2019 3:44 am

Heat is less likely. ESD is more likely. Are these OEM chips?
Welcome to the friendlier side of internet crazy :)

960
contributor
contributor
Posts: 311
Joined: Mon Dec 10, 2018 1:22 am
Soldering skill: yes
Coding skill?: yes

Re: Mary Shelley's Frankenso

Post by 960 » Wed Apr 03, 2019 4:25 pm

Dont think it's from heat.

I have heated IC's so they are almost rubber, and never destroyed any.

OrchardPerformance
contributor
contributor
Posts: 144
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

Re: Mary Shelley's Frankenso

Post by OrchardPerformance » Wed Apr 03, 2019 4:42 pm

Certainly not heat, I put it onto the other board to test/play with it and it works fine.

All the solder joints on the frankenso were OK so I have no idea why it didn't operate.

Either way, both MAX chips now work.

OrchardPerformance
contributor
contributor
Posts: 144
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

Re: Mary Shelley's Frankenso

Post by OrchardPerformance » Wed Apr 03, 2019 6:59 pm

Just achieved first start. rusEFI confirmed running on a 1980s BMW 325. (albeit not very well yet..)

User avatar
russian
Site Admin
Posts: 9770
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Mary Shelley's Frankenso

Post by russian » Wed Apr 03, 2019 7:09 pm

OrchardPerformance wrote:
Wed Apr 03, 2019 6:59 pm
(albeit not very well yet..)
Congrats! Can I please blame the tune?
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

OrchardPerformance
contributor
contributor
Posts: 144
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

Re: Mary Shelley's Frankenso

Post by OrchardPerformance » Wed Apr 03, 2019 7:17 pm

You can indeed, although at this point I would blame the tuner.... :lol:

I stuck it into wasted spark and batch injection just to avoid any possible sync errors so I have no idea what the injector pulse widths or the ignition timing was. I just need to sit down and work out what my idle pulse widths and timings should be, fortunately I have a mortronic ECU hooked up to run on the bench so I can sit in the warm with a scope and find that out at my leisure.

Hopefully get it running better at the weekend.
I will also get back to finishing off this build process as I have a load of notes and photos still to add.

OrchardPerformance
contributor
contributor
Posts: 144
Joined: Tue Jul 24, 2018 8:55 pm
Soldering skill: yes
Coding skill?: yes

Re: Mary Shelley's Frankenso

Post by OrchardPerformance » Sat Apr 13, 2019 10:58 pm

OK, so finishing off the build of the Frankenso before moving on to the vehicle specific bits on another thread.

------------------------------------------
Installed 5v rail jumper at W23

Installed LCD PWR Jumper

Fitted jumpers for Hi-Low driver voltages

Fitted jumpers for crank and cam sensor

It was at this point I put together a bench test rig so I could stimulate the outputs and debug the ECU on the bench.
I'm sure there are things I have missed from this build, I think its most likely I have missed some jumpers but the purpose of the bench test.

If there is enough want for it then I will do a quick round up of how I put the stimulator setup together.

Image

xtrap225
Posts: 3
Joined: Fri Aug 30, 2019 3:01 am
Soldering skill: yes
Coding skill?: yes

Re: Mary Shelley's Frankenso

Post by xtrap225 » Wed Dec 04, 2019 6:34 am

Thank you so much for this, its amazing to have something to use to get a good order to do the project in.

however, be warned folks there are at least a couple typos, i assume going by the BOM page for those would be best.
https://rusefi.com/docs/ibom/frankenso_latest.html

for example

LD604 and 3 others that are badly marked = LED, beware R604 is backwards vs the other 3 LEDs actually LD603 LD607 LD608
should say
LD604 and 3 others that are badly marked = LED, beware LD604 is backwards vs the other 3 LEDs actually LD603 LD607 LD608

and

C602 C604 = 1.0uF (104)
should say
C602 C604 = 0.1uF (104)

and

R172 R172 - Do not populate
should say
R172 R173 - Do not populate

and

C612 C613 = 3300pF (332)
should say
C162 C163 = 3300pF (332)

U531 = FT232RL http://www.ftdichip.com/Support/Documen ... FT232R.pdf
should say
U351 = FT232RL http://www.ftdichip.com/Support/Documen ... FT232R.pdf

Post Reply