Another microRusEFI DFU issue

It's all about the code!
Post Reply
dexter_lab
Posts: 17
Joined: Sun Feb 02, 2020 8:01 pm
Soldering skill: yes
Coding skill?: yes

Another microRusEFI DFU issue

Post by dexter_lab »

this is the result, no matter if powered via USB or via 12V and data via pin15,16

.\DfuSeCommand.exe -c -d --v --fn .\rusefi_mre-f4-test.dfu
1 Device(s) found :
Device [1]: STM Device in DFU Mode, having [4] alternate targets
Duration: 00:00:00
Target 00: Error Code: Unexpected error
Target: 00
Error Code: Unexpected error
TransferSize: 2048
DFU State: STATE_DFU_ERROR
DFU Status: STATUS_errVENDOR
Request: Clear Status Request.
CurrentNBlock: 0x0000
CurrentLength: 0x0005
Percent: 14

User avatar
AndreyB
Site Admin
Posts: 10357
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Another microRusEFI DFU issue

Post by AndreyB »

I occasionally see something like this maybe one time in 30 attempts but it just goes away by itself next time I try it.

Please show a screen shot of device manager showing DFU device connected, is it even getting that far?

Does you USB connection work for TunerStudio or rusEFI console?

Please provide more context. How are things powered etc. Please post a picture of your setup.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
AndreyB
Site Admin
Posts: 10357
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Another microRusEFI DFU issue

Post by AndreyB »

It is extremely unfortunate that a few important things were not mentioned:

1) custom USB connector is used - unknown part number vertical USB not microUSB
2) connector is inserted from the BACK not from the front
3) connector is not soldered

I am afraid to think what else is done in a custom way.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

dexter_lab
Posts: 17
Joined: Sun Feb 02, 2020 8:01 pm
Soldering skill: yes
Coding skill?: yes

Re: Another microRusEFI DFU issue

Post by dexter_lab »

Accept my apologies, Andry for missing information.
I want to try the new firmware. Initially I had downloaded a wrong file, but I was corrected by Matthew. My goal was to update
snapshot_20200319_211323_mre-f4_rusefi with snapshot_20200523_025511_mre-f4-test_rusefi.
I have MRE 0.4.7 enclosed in Mazda ECU box, I did not solder the micro usb connector as I have used a mini usb, but because the pins of mini are revers I have to stick it from the back of the plate (no pics for history). I did solder a Usb cable to 15( D-),17(D+) and 17(GND) and I have cut the 5V of the cable. Thus I have GND to PC via usb cable. Everything was working fine with this cable and old firmware connection to console and TS. However when I open the console to load the new firmware, the STM goes in DFU mode (I see it in hardware and com port is gone), but it was impossible to upload firmware. I have reached to a conclusion that my cables is bad and try to repeat the procedure via the mini USB that I have not soldered. Same result as with the cable. Matthew proposed to use STMCubeProgremmer. With this tools I was able to download the bin file of the new firmware to the MCU. Also I can return back to old firmware. Console is not working. I have notice that there is no STM in DFU mode any more in device manager but instead
STRM32 BOOTLOADER.

However with snapshot_20200523_025511_mre-f4-test_rusefi the MRE is starting in auto simulation mode with 1600RPM. I sow something similar somwhere but I could not find it how to fix

User avatar
AndreyB
Site Admin
Posts: 10357
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Another microRusEFI DFU issue

Post by AndreyB »

mre-f4-test is not the bundle you should be trying - you should trying mre-f4

Let me rename mre-f4-test into something more obvious to reduce the change of similar mistake
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

dexter_lab
Posts: 17
Joined: Sun Feb 02, 2020 8:01 pm
Soldering skill: yes
Coding skill?: yes

Re: Another microRusEFI DFU issue

Post by dexter_lab »

Updated to snapshot_20200523_112512_mre-f4_rusefi with success via STM32CubeProgrammer.
TS is working as well.
Thank you

User avatar
AndreyB
Site Admin
Posts: 10357
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City
Soldering skill: yes
Coding skill?: yes
Contact:

Re: Another microRusEFI DFU issue

Post by AndreyB »

dexter_lab wrote:
Sat May 23, 2020 9:32 pm
Updated to snapshot_20200523_112512_mre-f4_rusefi with success via STM32CubeProgrammer.
TS is working as well.
Thank you
Interesting, what would be a reasonable explanation?! We are using the older but still official command line tool.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

Post Reply