[rusEfi] 1993 Volvo 240 Turbo #30

What engine are you torturing? Is it inside some car?
Post Reply
mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

1993 Volvo 240 Turbo #30

Post by mck1117 »

Hello all!

Story time. I'm a computer science student at Georgia Tech in Atlanta, and I'm part of the Wreck Racing club. We build a car to compete in the Grassroots Motorsports $20xx Challenge. The premise is similar to that of LeMons racing, where we build an autocross and drag car for under the current year in dollars. This year we get a budget of $2017 (one additional dollar per year, for "inflation"). Our current car is a 2001 Honda Insight, but with the 3.3L engine from a Subaru SVX stuffed under the rear hatch, along with a Subaru 5 speed manual. We're currently running the stock Subaru ECU, but are trying to move to an aftermarket solution to give us better flexibility. We have run Megasquirt-1 on other cars, but it's incapable of doing sequential fuel and ignition. Megasquirt 2 and 3 can do it, but it's far too expensive to fit in our budget.

I'd started on a fully custom ECU solution, designed to be the bare minimum of hardware to do sequential ignition on a 6 or 8 cylinder, based around the STM32F373. Well, at least I was working on that until about a week ago, when I realized that rusEfi was almost exactly what we were looking for, so I decided to switch. I had the hardware mostly complete, and a first revision board in hand.

Over the past week I bodge-wired an STM32F4-Discovery to the rev 1 board, bypassing the 'F373. Tonight it ran an engine.

Image

This is my personal project car, a 1993 Volvo 240 Classic. The major modification (so far) is the addition of the turbo setup from a 1990 740, an IPD aftermarket camshaft, and a Megasquirt-2. I plan to use it as a flying testbed, as it's difficult to get a lot of running time on the racecar, as it's often taken apart. It's presently running batch fire fuel injection, and a distributor, but I'll switch to sequential fuel and ignition as I get everything working properly.

Here's the bodgewire adventure:

Image

At the left is a DB37 connector, so that I can plug the ECU in to my existing MS harness. The flying TO-220 part in front of the ribbon cable is a Fairchild FGP3040G2 IGBT ignition driver. At the top is an MPX4250 harvested from an MS. At the right is the standard F4 Discovery eval board (which I had lying around). In the center is the new custom board. This setup is super hacky, but I don't care since it was to prove that the hardware will work on the second spin of the board.

And here's a video of it running:

[video][/video]

In this video, coolant temp, intake temp, TPS and AFR are all bogus due to my own failure to order opamps that drive rail to rail. The MAP sensor works okay because the range I was running it in (20-100 kPa) doesn't exceed the limits of the ones I have.

Rev 2 is already in the works, using similar/the same ignition, low side driver, CAN, VR, etc. sections of the board, but placing the STM32F407VG on board instead of using the external Discovery.

User avatar
AndreyB
Site Admin
Posts: 10548
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: 1993 Volvo 240 Turbo #30

Post by AndreyB »

Wow. I've just added a special forum rank for people with an engine running rusEfi in first post.

Are you on turbobricks by any chance? Now I can start a rusEfi thread there unless you want to :)
Attachments
screenshot.png
screenshot.png (3.25 KiB) Viewed 8755 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

I am indeed on Turbobricks. Same username, if it matters.

User avatar
AndreyB
Site Admin
Posts: 10548
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: 1993 Volvo 240 Turbo #30

Post by AndreyB »

mck1117 wrote:I am indeed on Turbobricks. Same username, if it matters.
Ops :)

Anyway http://forums.turbobricks.com/showthread.php?t=329490
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
kb1gtt
contributor
contributor
Posts: 3649
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA

Re: 1993 Volvo 240 Turbo #30

Post by kb1gtt »

Very nice very nice.

Is your board layout something you can and are willing to share? If so I can offer a design review. More eyes can decrease the number of spins.

I'm sure you have found the wiki, but have you found the page which notes the design intent's of the hardware? If not here's a link. http://rusefi.com/wiki/index.php?title=Manual:Hardware also this page for PCB layout suggestions. http://rusefi.com/wiki/index.php?title=Manual:Hardware:PCB_design_rules

Very cool project, keep it up and feel free to ask questions.
Welcome to the friendlier side of internet crazy :)

sleepingAwake
Posts: 112
Joined: Fri Jan 13, 2017 4:15 am
Location: CT

Re: 1993 Volvo 240 Turbo #30

Post by sleepingAwake »

Very cool project.

If you ever feel like posting some info and pics on the insight/eg33 combo some of us (namely me) would appreciate it.

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

kb1gtt wrote:Very nice very nice.

Is your board layout something you can and are willing to share? If so I can offer a design review. More eyes can decrease the number of spins.

I'm sure you have found the wiki, but have you found the page which notes the design intent's of the hardware? If not here's a link. http://rusefi.com/wiki/index.php?title=Manual:Hardware also this page for PCB layout suggestions. http://rusefi.com/wiki/index.php?title=Manual:Hardware:PCB_design_rules

Very cool project, keep it up and feel free to ask questions.
Sure, I'd love a look from another set of eyes. I'm reasonably certain that it's at least mostly right, since all the interesting bits either got tested yesterday, or are lifted from the F4-Discovery/discovery replacement brain board.

Here's the board on GitHub: https://github.com/mck1117/wr-rusefi

One question actually, why is the BOOT0 pin pulled high, with a jumper to ground. That means the chip will boot in to the loader, unless there's a jumper present. Wouldn't it be safer to do the opposite, so that if you lose the jumper you can still drive the car home?

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

Finally, an update!

Many months ago I bought an assembled a Frankenso v0.4, and this past week I finally reworked my harness to run it.

[video]https://youtu.be/ANZWlBcKsFk[/video]

Look ma, no distributor!

In the process, I converted to sequential fuel and wasted spark. The little aluminum machined brick to the right of the ECU contains the two ignition drivers (wasted spark so 4/2=2 channels). I have an MPX4250 harvested from an old Megasquirt soldered in the prototyping area for MAP.

I copied the fuel/AFR/ignition tables I was using on Megasquirt, and it runs great. I have about 50 miles on the car since I switched ECUs, and I've been to both redline and wide open (~8-9 psi) without any issues.

Acceleration enrichment still needs some help in the low RPM, 0% -> 25% throttle range, but overall drivability is quite good. Medium RPM, light throttle is quite a bit smoother, but I'm not sure if that's an artifact of replacing the whole ignition system, sequential fuel, or the new ECU.


One problem: It takes a VERY long time for the stm32 discovery to actually boot, but only when I'm not plugged in to the programming USB port. About two seconds from when the key is turned on (and red power LEDs come alive) to when the blue LED starts flashing on the stm32.

Here's what I mean:

[video]https://youtu.be/YdbUZ7U-Xf0[/video]

Any idea why this happens?

User avatar
AndreyB
Site Admin
Posts: 10548
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: 1993 Volvo 240 Turbo #30

Post by AndreyB »

This sounds like http://rusefi.com/forum/viewtopic.php?t=1027 - that would be about stm32f4discovery powered via the 5m pins. Updating the discovery own firmware (not rusEfi firmware) was improving things.

This reminds me about testing http://rusefi.com/forum/viewtopic.php?f=4&t=381 and listing those for sale. Without on-board debugger it would be a bit simpler with less moving pieces.
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

Fixed by removing SB11 and R68 from the bottom of the bottom of the discovery board.

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

Well, after maybe 100 miles of driving on RusEfi, I took a road trip from Atlanta to Surf City, NC for the weekend. About 450 mile drive. Cruised at 70-80, got about 23-25 mpg. Not too bad for a meh quality tune, a turbo, all terrain tires, and too high a 5th gear ratio.

stefanst
contributor
contributor
Posts: 619
Joined: Wed Feb 17, 2016 12:24 am
Location: USA 08530

Re: 1993 Volvo 240 Turbo #30

Post by stefanst »

mck1117 wrote:Well, after maybe 100 miles of driving on RusEfi, I took a road trip from Atlanta to Surf City, NC for the weekend. About 450 mile drive. Cruised at 70-80, got about 23-25 mpg. Not too bad for a meh quality tune, a turbo, all terrain tires, and too high a 5th gear ratio.
That's great news! What AFRs are you running in cruise?

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

stefanst wrote:
mck1117 wrote:Well, after maybe 100 miles of driving on RusEfi, I took a road trip from Atlanta to Surf City, NC for the weekend. About 450 mile drive. Cruised at 70-80, got about 23-25 mpg. Not too bad for a meh quality tune, a turbo, all terrain tires, and too high a 5th gear ratio.
That's great news! What AFRs are you running in cruise?
We were tuning cruise on the run so it improved as we went, but by the end it was pretty on target at 14.7-15.0 in the 2000-3000 rpm/50-90kpa range. The first 2/3 of the drive averaged 23mpg, and we did most of tuning right after the fuel stop.

This combination of cam, turbo, and manifold absolutely kills VE out of boost, so cruising at 75-80 mph requires about a 70-75kpa manifold pressure. That feels really high, but the actual cylinder pressures aren't very high because the VE is so bad. It could probably take some more timing in that range, but until I'm on a dyno or have the knock sensor hooked up I'm not going to push it.

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

The news to update on this car is that there isn't much news. I've put ~5000 miles on the car with Rusefi, with no real issues. Gets pretty decent milage, mid 20s for a 25 year old turbo wagon brick.

The big news is the future: I have, sitting in my garage, a freshly rebuilt LS iron block 5.3, and a T56 from a CTS-V.

User avatar
AndreyB
Site Admin
Posts: 10548
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: 1993 Volvo 240 Turbo #30

Post by AndreyB »

Iron block LS does it mean its from a truck? Mechanical throttle?

That's some sweet news :)
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
kb1gtt
contributor
contributor
Posts: 3649
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA

Re: 1993 Volvo 240 Turbo #30

Post by kb1gtt »

That's some sweet news. Thanks for the update. Also cool to hear it's getting some fresh mechanical bits.
Welcome to the friendlier side of internet crazy :)

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

Yep, best I can tell it's a 2002 year flex fuel truck engine, code L59. I put a cam in it, new lifters, new bearings, new pistons (I used the pistons from a 4.8 instead, same compression height but flat top instead of dish, gives ~10.3:1 compression), and used (but refurb) gen4 rods. Stock plastic truck intake, and currently a cable throttle body (but I'll probably go to ETB at some point).

User avatar
AndreyB
Site Admin
Posts: 10548
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: 1993 Volvo 240 Turbo #30

Post by AndreyB »

@ says
Attachments
image_from_ios_1024.jpg
image_from_ios_1024.jpg (193.15 KiB) Viewed 6739 times
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

User avatar
kb1gtt
contributor
contributor
Posts: 3649
Joined: Tue Sep 10, 2013 1:42 am
Location: ME of USA

Re: 1993 Volvo 240 Turbo #30

Post by kb1gtt »

Sweet. Looks nice. I believe I see ETB and WO2 adders.
Welcome to the friendlier side of internet crazy :)

Abricos
contributor
contributor
Posts: 783
Joined: Mon Aug 18, 2014 12:32 am

Re: 1993 Volvo 240 Turbo #30

Post by Abricos »

@mck1117 do you have. stl from this box ... how you cut cnc or laser ???

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

I do! I modeled in Solidworks, then laser cut from 1/8" acrylic. Attached to this post is a zip with the SW files, in addition to the dxfs for each part.
Attachments
case.zip
(882.26 KiB) Downloaded 112 times

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

kb1gtt wrote:
Fri Jan 11, 2019 5:03 pm
Sweet. Looks nice. I believe I see ETB and WO2 adders.
Yep. Pololu MC33926 board for ETB at the left (not fully wired in yet, only run on the bench), and cj125 in the middle. Cj125 has been working for ~2500 miles so far and works great.

User avatar
AndreyB
Site Admin
Posts: 10548
Joined: Wed Aug 28, 2013 1:28 am
Location: Jersey City

Re: 1993 Volvo 240 Turbo #30

Post by AndreyB »

mck1117 wrote:
Sun Jan 13, 2019 7:57 am
Pololu MC33926 board for ETB at the left (not fully wired in yet, only run on the bench)
Poke about that code merge :roll:
https://rusefi.com/s/howtocontribute
very limited telepathic abilities - please post logs & tunes where appropriate - http://rusefi.com/s/questions
my skype is arro239

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

Progress, progress...

Image

puff
contributor
contributor
Posts: 2813
Joined: Mon Nov 11, 2013 11:28 am
Location: Moskau

Re: 1993 Volvo 240 Turbo #30

Post by puff »

v8?

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

V8! 5.3 liter iron block gen3 small block. Flat top pistons so it's around 10:1 compression, medium size cam. Six speed manual t56 from a Cadillac CTS-V.

mck1117
running engine in first post
running engine in first post
Posts: 460
Joined: Mon Jan 30, 2017 2:05 am
Location: Seattle-ish

Re: 1993 Volvo 240 Turbo #30

Post by mck1117 »

Thus marks the conclusion of this thread. This car has been running the v8 for a few months on the GM computer, and yesterday ran on rusEfi for the first time!



New thread: https://rusefi.com/forum/viewtopic.php?f=3&t=1648

Post Reply